ERROR: "Index was outside the bounds of the array"

Simon.AndersonSimon.Anderson Posts: 3
edited July 30, 2014 10:34AM in Schema Compare for Oracle
I'm trying to compare two development schemas, but I get the same error when I try to take a snapshot of one of them:

The process aborts, with the message "index was outside the bounds of the array"

Any ideas where I should start looking for the issue?

Comments

  • If you can take a look in your log file, the scripts we use to populate data are there so you can see if they are returning "sensible" data.

    http://documentation.red-gate.com/displ ... +log+files
    Richard Mitchell
    Project Manager
    Red Gate Software Ltd
  • Thanks for that - but now I'm even more confused!

    I set the logging to 'verbose' and found an error where it's trying to look at the Column comments: some of them were fairly long, and some contained single quotes as part of the text

    But, having removed all the comments on the columns, although running the query directly returns no rows, I'm still getting the same error in the log:

    SELECT
    com.owner,
    com.table_name,
    com.column_name,
    com.comments
    FROM dba_col_comments com
    WHERE (com.owner = 'MYSCHEMA' ) AND com.comments IS NOT NULL
    15:20:36.601|Debug |Object Model |9 |:Query returned reader in : 1 ms
    15:20:36.771|Debug |Object Model |9 |:Populating columns took 1192 ms
    15:20:36.791|Error |Engine Service |1 |:Exception in progress dialog
    RedGate.Oracle.Common.DetailedPopulationException: Index was outside the bounds of the array. ---> System.IndexOutOfRangeException: Index was outside the bounds of the array.
    at RedGate.Oracle.Utils.DataReaders.ArrayDataRecord.#4FD(String #hvPb)
    at RedGate.Oracle.Common.Datatypes.DatatypeBuilder.GetDatatype(IDataRecord reader, Boolean includeNestedTables)
    at RedGate.Oracle.SchemaCompare.ObjectModel.DatabaseFactory.#8WD()
    at RedGate.Oracle.SchemaCompare.ObjectModel.DatabaseFactory.#tE6d()
    at RedGate.Oracle.SchemaCompare.ObjectModel.DatabaseFactory.#C3.#ZSD(Action #sxPb, String #utPb)
    at RedGate.Oracle.SchemaCompare.ObjectModel.DatabaseFactory.Populate()
    --- End of inner exception stack trace ---
    at RedGate.Oracle.SchemaCompare.ObjectModel.DatabaseFactory.Populate()
    at RedGate.Oracle.SchemaCompare.ObjectModel.LivePopulator.Populate()
    at RedGate.Shared.Controls.ProgressDialogEx.<>c__DisplayClass7.<DoTasks>b__4(Object q)

    Tried restarting the app, makes no difference...
  • Can you send your log file to [email protected] and we can continue that way.

    Sorry you're hitting an issue :(
    Richard Mitchell
    Project Manager
    Red Gate Software Ltd
Sign In or Register to comment.