profiling 32 bit application on windows server 2012

snow_capsnow_cap Posts: 4
edited July 24, 2014 3:20PM in ANTS Performance Profiler 8
Hi All,

Am trying to profile a 32 bit web application on a windows 2012 server where sharepoint 2013 is installed.

The error found in event viewer is as below:
The Module DLL 'C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\15\isapi\owssvr.dll' could not be loaded due to a configuration problem. The current configuration only supports loading images built for a x86 processor architecture. The data field contains the error number.

Knowing that my 32 bit application is running with no problems.

My question would be what application pool ants performance profiler is using bye default when selecting unused port?

Is it possible to configure the application pool of the ants performance profiler if it is not using the default application pool of the .net web applicaiton?

I tried to deny the ISAPI\CGI restrictions of the mentioned dll above but with no luck.

I even tried the above on a windows 7 machine where sharepoint 2010 is installed but same issue.

Any help would be highly appreciated.

Thank you


  • Jessica RJessica R Posts: 1,319 Rose Gold 4
    Hi there,

    Thanks for your post!

    Just to confirm--is the website you are trying to profile a sharepoint application?

    The profiler creates an AppPool called "RGTestAppPool" to run your application, copying information from your applicationHost.config file to do this.

    I'm going to shoot you an email in a few moments--could you kindly reply to that and attach the most recent .config files that ANTS has created so I can take a look? They are located in %localappdata%\Red Gate\ANTS Performance Profiler 8Thanks!

    Jessica Ramos | Product Support Engineer | Redgate Software

    Have you visited our Help Center?

  • Hi,

    The website am trying to profile is not a sharepoint application.

    I can't find a .config files,only .xml.

    Thank you
  • Hey Jessica,

    Thank you for pointing me to the right direction the solution for the above is to excute the below line under c:\windows\system32\inetsrv\ in command prompt

    appcmd.exe set config -section:system.webServer/globalModules /[name='SharePoint14Module'].preCondition:integratedMode,bitness64
Sign In or Register to comment.