Packager not discovering difference in data

paulpaul Posts: 14
edited April 10, 2006 12:29PM in SQL Packager Previous Versions
I noticed a problem with the generated data script in Packager not finding a difference in data between 2 tables. I have 2 databases which are identical (both were created using same package for testing reasons). I then open a table and change some data. This table where I changed data has 2 columns, an int and a smalldatetime, and data were updated in both columns. I then run Packager in an upgrade database format, with the database that has updated data being the latest version. No schema objects are found to be different, which is expected as only data has changed. Then on the data screen I only select the table in which I have changed the data. Then in the data script there is no sql for updating the data. It did not find the differences.

I ran the same comparison using SqlDataCompare and it found the differences just fine.

Why would this simple difference between databases not be seen by Packager?

Thanks for any help.

Comments

  • Brian DonahueBrian Donahue Posts: 6,590 New member
    Hi,

    This isn't the command-line version of Packager, is it? We've found some discrepancies between the GUI and command line version in the way that it handles tables between two databases.
  • This problem is occurring with the GUI version of Packager.

    Thanks,

    Paul
  • Hi Paul,

    thanks for pointing this out. I could reproduce it here. It seems to happen everytime when there is no difference in the schema. It should work when the schema is different. Sorry about that. We will fix it for the next release.

    Tilman
Sign In or Register to comment.