xp_sqlbackup.dll error log shipping restore

MarkSMarkS Posts: 2
edited April 14, 2006 10:09AM in SQL Backup Previous Versions
SQL Backup 4.1.0.207
SQL Server 2000 Win 2003
Our scheduled log file restores were working for several days and now fail with the message:
Access violation at address 041F82C3 in module 'xp_sqlbackup.dll'. Write of address 00000000 [SQLSTATE 01000] (Message 0). The step succeeded.

We stopped the service, restarted and also stopped SQL server and restarted, but still get the same error (although it reports as a success, the logs are not restored).

Comments

  • Brian DonahueBrian Donahue Posts: 6,590 New member
    Hi,

    I think the COPYTO command used for the log shipping doesn't work in SQB 4.1 if the backup history table can't be updated. The last thing SQL Backup does is execute the COPYTO to put the log backup on the share and if SQL Backup fails when writing the backup history, it never gets to the COPYTO.

    If you'd be kind enough to email [email protected], I'll pt you on the list to let you know when there is a fix, if this is indeed the problem you're having.
  • Can you tell me what the value of the following registry keys is please:

    HKEY_CLASSES_ROOT\CLSID\{40700425-0080-11d2-851f-00c04fc21759}\InprocServer32 \ThreadingModel

    HKEY_CLASSES_ROOT\CLSID\{b5e7a132-a7bd-11d1-84c2-00c04fc21759}\InprocServer32 \ThreadingModel
    - Neil Davidson
    Red Gate Software Ltd
  • @version will tell you this).
    - Neil Davidson
    Red Gate Software Ltd
  • Brian DonahueBrian Donahue Posts: 6,590 New member
    Please write [email protected]. We have a fixed xp_sqlbackup.dll that should prevent this. This is specifically for version 4.1 or SQL Backup. If you have got a patch from us already to 4.2, be sure to let us know or we'll send you the wrong dll.
Sign In or Register to comment.