SQL Data Compare Ate My Hard Drive!

I'm sure that SQL Data Compare 4 is using Hard Drive Space when doing it's comparsion, but is there some way to point it to using another Hard Drive? While comparing the data between two very large databases, I ran out of space on my C: Drive, but I have over 300 gig of free space on my F: Drive. I would like SQL Data Compare 4 to use that space and not the space on my C: Drive.

Mark Trammell
AgFirst Credit Bank

Comments

  • Hi Mark,

    SQL Data Compare 4 uses your temp directory to store its working files so if you alter your TEMP environmental variable you can point SDC4 at another drive.

    SQL Data Compare 5 (which is currently in public beta - see http://www.red-gate.com/messageboard/viewforum.php?f=35) has some extra support for this - in RC1 we support a environmental variable called RGTEMP which allows you to tell Data Compare where to store its working set however this does not currently change where synchronization SQL scripts etc are generated so there will still be some quite heavy usage of your temp folder. This issue with the location used for SQL Generation is fixed in the final release of Bundle 5 – due to be released in early April.

    I hope this helps,

    - James
    --
    James Moore
    Red Gate Software
    James Moore
    Head of DBA Tools
    Red Gate Software Ltd
  • Ok ... I went into the Environmental Variables and changed where SYSTEM VARIABLES (It is the system variables I should change correct?) TEMP and TMP are pointing to, now they point to F:\WINNT\TEMP. I created the directories on the F: Drive F:\WINNT and F:\WINNT\TEMP. So I'll try this later on re-running SQL Data Compaere 4 and see if it works, the data compare is going to take several hours anyway.

    Mark Trammell
    AgFirst Credit Bank

    PS.
    I know this sounds like a plug for you guys, but Red-Gate's whole SQL Package is great!! The best thing out there!! I use SQL Compare and SQL Data Compare everyday ... and could not do my job without.
  • Brian DonahueBrian Donahue Posts: 6,590 New member
    Hi Mark,

    Thanks for the kudos! BTW you'll want to change TMP in the user block rather than the system block, then log off and on again. That is, of course, unless you're automating SQLCOMPARE.exe using the LocalSystem account to run the scheduled task -- then it would all go to the system's TMP area.
  • Ahhh ... that would explain why the next day I found the same problem had occured when I came in the next day. I didn't have the time to work on it or investigate it, so I moved on to other projects and figured I'd get back to it.

    Ok. My User variables from my login are:

    TEMP & TMP : %USERPROFILE%\Local Settings\Temp

    I think I tried changing this twice - (I think I did, may not have. May have only changed it once) - and it kept coming back to this.

    Am I doing something wrong?

    Mark Trammell
    AgFirst Credit Bank
  • Brian DonahueBrian Donahue Posts: 6,590 New member
    Hi Mark,

    It sounds like you'd done it right -- provided you'd changed TMP to another whole hard disk with lots of free space. You also definitely need to log off and on again for the changes to set.
Sign In or Register to comment.