Add-in SQL Source control failed to load

pdherderpdherder Posts: 4
edited December 6, 2016 1:40PM in SQL Source Control Previous Versions
When starting SSMS 2012 I receive the following error message:
The Add-in 'SQL Source Control 3' failed to load or caused an exception. Would you like to remove this Add-in? If you choose yes, the file it was loaded from 'C:\ProgramData\Microsoft\SQL Server Management Studio\11.0\\Addins\RedGate.SQL SourceControl.SSMSUI.2012.addin', will be renamed.

Error Message: The system cannot find the file specified.

Error number: 80070002

I removed the product and reinstalled it, but that does not help. I also tried the option renaming the folder C:\Users\youruserprofile\AppData\Local\Red Gate\SQL Source Control 3 but even that does not seem to fix it.

I have the exact same problem with SSMS 2008 R2.

Please help

Kind regards,



  • I had the same issue this morning with Source Control not loading the add-in, after receiving the same error message "The Add-in 'SQL Source Control 3' failed to load or caused an exception...".

    In order to have the AddIn work again, I edited the "RedGate.SQLSourceControl.SSMSUI.2014.addin" file from the location path "C:\ProgramData\Microsoft\SQL Server Management Studio\12.0\Addins". You have to set the LoadBehavior element to a numeric one. Take note, there is also another subfolder in SQL Server Management Studio with the same set of files (i.e. 11.0). You may also have to edit that file as well.
  • John, thank you for your answer, but unfortunately does not solve this my problem. When I restart SSMS 2012 the error shows up again and the LoadBehavior element is set back to 0.
  • Hi Peter,

    Stuff like this is often very hard to troubleshoot, because we get very little information about what specifically is going wrong - all we can tell is that SSMS is failing to find some file, but if SQL Source Control didn't throw an error during install we'd expect all of the correct files to be in the right place.

    It sounds like you've already tried almost all of the things we'd recommend - the only other thing I can offer that other users have said has helped in the past is uninstalling SQL Source Control, performing a repair installation on SQL Server and reinstalling the product. Do you have other SSMS plugins installed, like SQL Prompt? Do they have the same issue?
    Andy Campbell Smith

    Red Gate Technical Support Engineer
  • Hi Andy,

    I tried your suggestion, but it did not solve my problem. The other addins like SQLPrompt, work without problems. Only with Connect I receive error messages, but this is a Visual Studio addin.
    The problems started after the false positive warning of ESET anti-virus.

    I guess that I have to do a complete reinstall of my computer. But that is not very tempting.
  • New to SQL and was wondering if someone could help me understand what is this all about. I have gone and read topics listed on google and just not managed to grasp the idea. Your insight to the matter will be most appreciated.
  • Peter:

    We've actually had a few reports since the most recent ESET false positive - can you double check that ESET hasn't automatically set up some rules do nuke any Red Gate DLLs? As I recall, that was once a problem before.


    Are there any specific questions you've got that I can help you with? It might be worth starting your own thread if you're not getting the specific "Add-in failed to load" error message, but we'll be happy to help out all the same - alternatively, you can email [email protected].
    Andy Campbell Smith

    Red Gate Technical Support Engineer
  • I just ran SSMS as an Administrator and then click yes to rename the addin. This resolved my issue.
Sign In or Register to comment.