Cannot use SQL Search 2 at all

perrydrewperrydrew Posts: 2
edited May 27, 2014 12:00AM in SQL Search
I get this error every time I try to run SQL Search 2 on my SSMS of 2008R2.
I rebooted and uninstalled and reinstalled and no change. The previous version of SQL Search ran with no problems. I am running Windows 7.

Perry

Could not load file or assembly 'file:///C:\Program Files (x86)\Red Gate\Deployment Manager SSMS add-in 1\System.Data.SQLite.dll' or one of its dependencies. This assembly is built by a runtime newer than the currently loaded runtime and cannot be loaded.

Comments

  • Hi Perry,

    The DM addin and Search uses the common SSMS addin framework. You can disable the DM addin by removing it's registry key from this location:

    HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Red Gate\SIPFramework\Plugins

    I'll raise this with the DM team too, maybe they recognise this issue.

    David
  • Hi David,

    Can you be more specific about what to remove from the registry location you mentionned?
    Patrick
  • The Deployment Manager SSMS addin adds a key called "HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Red Gate\SIPFramework\Plugins\DeploymentManagerSqlServerDbPackage". Removing this key will stop the DM addin from loading into SSMS.

    I was thinking about the root cause of this problem. Presumably this happens when you click SQL Search's toolbar button? If possible please could you email me a log file from an SSMS session where the problem occurs. The log files are here:

    C:\Users\<your.username>\AppData\Local\Red Gate\Logs\Ssms

    My email address is [email protected].

    David
  • EnrightMcCEnrightMcC Posts: 14 Bronze 2
    I experienced this today when I tried to upgrade to SQL Search 2. When I click on the button I receive the error listed in the OP.

    What is the status of this?
    Can you provide a link to reinstall a previous version?

    FYI my log info is:
    15:29:37.187|Info |RedGate.SIPFramework|1 |Red Gate SSMS Ecosystem host connecting to SSMS.
    15:29:37.187|Info |RedGate.SIPFramework|1 |RedGate.SIPFramework version: 1.0.1.2025
  • EnrightMcC,

    If you follow David's workaround (remove from registry) the SQL SEARCH 2 will work. In regedit:
    1 - I exported the portion of the registry under "HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Red Gate\SIPFramework\Plugins\"
    2 - I deleted "HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Red Gate\SIPFramework\Plugins\DeploymentManagerSqlServerDbPackageI deleted"
    Now, if you restart SSMS and click on the SEARCH button, It should work.
    You can even reimport the registry setting and it still will continue working (or at least it did for me as I was trying to reproduce the problem).

    I hope this helps.
    Patrick
  • YDCYDC Posts: 3 Bronze 1
    I also used the workaround including recreating the DeploymentManagerSqlServerDbPackage key.

    It worked!

    Thanks
  • EnrightMcCEnrightMcC Posts: 14 Bronze 2
    Yep, that did it. Thanks to patrickortuso and David Pond. Deleting the DM key seems to have done the job.
  • Thanks all for the feedback and I'm glad David's suggestion of deleting the Deployment Manager Add-in seems to be working for you.

    Our developers are still trying to reproduce this issue, but we haven't had any luck so far, I'm afraid.

    To help us, it would be really helpful if anyone who has this issue could let us know the following, please:

    - Which versions of SSMS you have installed
    - Which version of SSMS you are using
    - The OS version
    - Any other plug-ins you have installed in SSMS

    Thanks,
    Dom.
    Dominic Smith,
    Project Manager,
    Redgate.
  • EnrightMcCEnrightMcC Posts: 14 Bronze 2
    Only one version installed. Here is the info from SSMS Help--> About
    Microsoft SQL Server Management Studio 10.50.4000.0
    Microsoft Analysis Services Client Tools 10.50.4000.0
    Microsoft Data Access Components (MDAC) 6.1.7601.17514
    Microsoft MSXML 3.0 4.0 6.0
    Microsoft Internet Explorer 9.11.9600.17041
    Microsoft .NET Framework 2.0.50727.5477
    Operating System 6.1.7601

    Windows 7 Professional

    No other plugins installed.
  • Once again, thanks for all the responses on this issue. We've managed to reproduce it and we have released a new build of SQL Search with the fix.

    If you are affected, you can download the new version from http://www.red-gate.com/products/sql-development/sql-search/v2

    Thanks,
    Dom.
    Dominic Smith,
    Project Manager,
    Redgate.
  • Yep, that did it. Thanks to patrickortuso and David Pond. Deleting the DM key seems to have done the job.

    I did that once before... It seemed to work for me.
Sign In or Register to comment.