SQL Search 2

sarisettysarisetty Posts: 2
edited February 19, 2015 10:11AM in SQL Search
I did face the same problem when I installed it for the first time, the search was fast enough compared to its predecessor(Sql Search V1), however it consumes the whole processing and leaves us no choice other than killing the process through task manager.

Repair the SSMS Integration Pack Framework & Sql Search 2 through the Control Panel MMC Snap-in(appwiz.cpl) and restart the ssms process again. It shouldn't freeze now :)

P.S: The solution proposed by me is temporary, it might be resolved by red-gate team soon in the new versions.


  • Options
    I tried sarisetty solution to repair SSMS Integration Pack Framework & Sql Search 2. I also downloaded the latest version of sql search 2. Uninstalled a installed again, to no avail
    Help please.
  • Options
    I have this problem too.

    I can do a repair of both programs and sometimes get it working for several days.

    Then today, nothing I do fixes it and whenever I click the search button SSMS freezes and I have to kill the process.

    I would switch back to version 1 but I can't find the install executable.
  • Options
    Same here, "Search" can work for a day or a couple of hours and then freezes. I am going through the same steps; uninstall, re-install and hopping that it will work. Sometimes takes couple of times to do that. It became a game of sorts, click on the SQL Search and hold my breath.
    Which SQL Server version are you using? I think that SQL Search 1 doesn't work with SQL 2014.
  • Options
    yshmidt wrote:
    ...click on the SQL Search and hold my breath.
    Heh, yup.
    yshmidt wrote:
    Which SQL Server version are you using?
  • Options
    We dropped a table and then removed it from all the Stored Procedures that called it. When we search for the name of the table it is still showing up. I have tried to click Reindex and manually deleted the Indexes in my user folder. Can anybody please help?
    We offer guaranteed success for Pass4sure 300-207 exam with help ccna and ccnp of latest certification and practice questions and the exams of sterling ccie security www.mcdaniel.edu
  • Options
    The only way I have been able to resolve this issue is to close SQL Server Management Studio, then delete the index files at the following location (WIndows XP):
    C:Documents and Settings*USERNAME*Local SettingsApplication DataRed GateSQLSearch 2Indexes
    These files are re-created the first time you perform a search.
Sign In or Register to comment.