Error while launching monitor website after install

RT01RT01 Posts: 2
edited April 30, 2014 7:49AM in SQL Monitor Previous Versions
Hi,

I installed SQL Monitor web server (XSP) and base monitor successfully. After launching the website, I get the following error when I click the button "Connect to Base Monitor".

"Authentication failed because the remote party has closed the transport stream."


Error in Event Viewer:
2014-04-28 22:05:54,654 [18] ERROR RedGate.Response.Common.Utilities.ThreadPools.ErrorReportingThreadPool [(null)] - Unhandled exception in thread pool
System.ComponentModel.Win32Exception (0x80004005): The credentials supplied to the package were not recognized
at System.Net.SSPIWrapper.AcquireCredentialsHandle(SSPIInterface SecModule, String package, CredentialUse intent, SecureCredential scc)
at System.Net.Security.SecureChannel.AcquireCredentialsHandle(CredentialUse credUsage, SecureCredential& secureCredential)
at System.Net.Security.SecureChannel.AcquireServerCredentials(Byte[]& thumbPrint)
at System.Net.Security.SecureChannel.GenerateToken(Byte[] input, Int32 offset, Int32 count, Byte[]& output)
at System.Net.Security.SecureChannel.NextMessage(Byte[] incoming, Int32 offset, Int32 count)
at System.Net.Security.SslState.StartSendBlob(Byte[] incoming, Int32 count, AsyncProtocolRequest asyncRequest)
at System.Net.Security.SslState.ProcessReceivedBlob(Byte[] buffer, Int32 count, AsyncProtocolRequest asyncRequest)
at System.Net.Security.SslState.StartReadFrame(Byte[] buffer, Int32 readBytes, AsyncProtocolRequest asyncRequest)
at System.Net.Security.SslState.StartReceiveBlob(Byte[] buffer, AsyncProtocolRequest asyncRequest)
at System.Net.Security.SslState.ForceAuthentication(Boolean receiveFirst, Byte[] buffer, AsyncProtocolRequest asyncRequest)
at System.Net.Security.SslState.ProcessAuthentication(LazyAsyncResult lazyResult)
at System.Net.Security.SslStream.AuthenticateAsServer(X509Certificate serverCertificate, Boolean clientCertificateRequired, SslProtocols enabledSslProtocols, Boolean checkCertificateRevocation)
at #1jv.#nkv.#RLv(Stream )
at #1jv.#0jv.#yco(Socket )
at #1jv.#0jv.#A2.#SLv()
at #djJ.#S47.#Pa8(#Q47 )
at #djJ.#S47.#u3.#tWe()
at #djJ.#gjJ.#u3.#tWe(Object )


The host, url, port are all correct.
Checked the services and both web and monitor are running.
Tried using IIS 7.0 and its the same error.
Changed the service account using a domain account with local administrator privilege, but no luck.

Any help is highly appreciated.


Thanks,
RT
Tagged:

Comments

  • Brian DonahueBrian Donahue Posts: 6,590 New member
    Hi RT,

    This happens a lot. The first thing to try is to locate c:\programdata\red gate\sql monitor 4\Red gate monitor.pfx and delete it. That is the encryption certificate and it should get re-created next time you try to access SQL Monitor.

    The next thing is to check if that does not work is the application pool for the app that is running SQL Monitor to ensure the configured identity is an account with sufficient rights to create and use encryption certificate files. Try with SYSTEM and if that works, you can try a lesser-privilege account.

    If you need more specific instructions, please let me know. There are a lot of variables in IIS config and I can't describe every possibility without boring everyone tremendously.
  • dyarddyard Posts: 2 New member
    I tried this and it still doesnt work is there any other suggestions?
  • dyarddyard Posts: 2 New member
    Authentication failed because the remote party has closed the transport stream.
  • Hi all,

    David, I worked with you on the support ticket last week which didn't directly address this (we got it working on the later version that wasn't getting this issue) but having seen this outstanding, I thought I would update it for anyone else experiencing this issue.

    ****This only applies to versions before 7.0.5****

    I believe this error: "Authentication failed because the remote party has closed the transport stream." is related to not having TLS 1.0 and/or SSLv3.0 enabled on the system running the SQL Monitor Base Monitor and SQL Monitor Web Service services. This post goes over the registry settings to enable both the client and server portions of TLS1.0 and SSLv3.0.

    You may also need to ensure that the user running the SQL Monitor Web Service (or the application pool identity for IIS installs) has the permissions from this page and in some circumstances those listed by Brian above as well.

    ****In Versions 7.0.5 and later****
    SQL Monitor supports all TLS versions and SSLv3.0 in this order: TLS1.2, TLS1.1, TLS1.0 and finally SSLv3

    I hope that helps!

    Kind regards,
    Alex
    Product Support Engineer | Redgate Software

    Have you visited our Help Center?
Sign In or Register to comment.