What are the challenges you face when working across database platforms? Take the survey
Options

Using sqb2mtf tp convert a multi file backup

As part of our DR procedures we want to start to use the Redgate option option "Split backup into multiple files". This is to reduce the size of a single backup file to make things easier when we manually copy the backups to a 3rd location. As part of out testing I now need restore this backup onto a server which does not have redgate. I've used the sqb2mtf utility to convert the seperate files from .sqb to .bak, but when I try to restore the backup using the following command:

RESTORE DATABASE [Live_Reports] FROM DISK = N'F:\MultiFile\FULL_Live_Reports_20140414_081818_01.bak', DISK = N'F:\MultiFile\FULL_Live_Reports_20140414_081818_02.bak' WITH FILE = 1, MOVE N'Live_Reports' TO N'G:\MSSQL\SQL.DATA\Live_Reports.mdf', MOVE N'Live_Reports_log' TO N'E:\MSSQL.1\LOGS\Live_Reports.ldf', NOUNLOAD, STATS = 10
GO

I get the error:

Msg 3183, Level 16, State 1, Line 1
RESTORE detected an error on page (1:100919) in database "Live_Reports" as read from the backup set.
Msg 3013, Level 16, State 1, Line 1
RESTORE DATABASE is terminating abnormally.

The server I have tried this on does have Redgate installed and I can sucessfully restore the .sqb files using the Redgate GUI. I have tried to running sqb2mtf and restoring twice and get the same error both times but on different pages.

Can anybody confirm if they have sucessfully converted a multi file backup from .sqb to .bak and been able to restore it.

Comments

Sign In or Register to comment.