Error: The given key was not present in the dictionary.

mario17mario17 Posts: 15
I persistently have this error trying to get latest version from our SC (Subversion).

Read many threads but looks like it's all individual solution, can I get support to resolve it.

Thanks
Victor

Comments

  • mario17mario17 Posts: 15
    edited March 27, 2014 1:37AM
    Bump,
    Sent error message to Red Gate, can you help.
    What key ? What dictionary ?
    Is it about RG or/and SQL Server 2012, windows 7?

    I"m on standalone machine, SA, Admin etc..


    Tx for help
    V

    Below I put header of error message:
  • System.Collections.Generic.KeyNotFoundException: The given key was not present in the dictionary. System.Collections.Generic.KeyNotFoundException: The given key was not present in the dicbonary. at System.Collections.Generic.Dictionary. 2.getitem(They key) at RedGate.SQLSourceControl.Engine.Diff.Collections.DatabaseObjectIdDictionary* tgetitem(DatabaseObjectId key) at ,IGWeb.,4,1XM.:$1Hdb(DatabaseObjectId , IEnumerable' 1) at ,4,`GWeb.t.XXM.;;Xvc.,13Dwd(DatabaseObjectId ) at System.Linq.Enumerable.<>c_DisplayClassf 1. CombinePredicates>b_e(TSource x) at Systemlinq.Enumerable.WhereEnumerableIterator*l.MoveNexto at RedGate.Shared.Utils.Collections.See 1..ctor(IEnumerable 1 src, IEqualityComparer ' 1 comparer) at ttGWeb.:OO(M.,:Xt3(DatabaseObjectIdSet ) at **Web. AtXXM. tskFc0 at *GWeb. #XXM.,tetYMO at ,4,`GWeb.*XXM.,:qYMO
  • James BJames B Posts: 1,124 Silver 4
    To be able to help, we need to see the full error report. Please send this to us, making sure you put your email address in the box provided; this will enable us to find it in our system.
    Systems Software Engineer

    Redgate Software

  • xanxan Posts: 5 Bronze 1
    We have just started seeing this error on one of our source controlled databases. 3 of our developers are getting this in various situations.

    Is there any update for possible fixes? I've submitted a number of bug reports / crash reports via the popup. Can anyone comment?

    The use case that is now tripping us up is as follows:


    * We use local individual development databases, linked to source control as "dedicated" - these all work fine, we've encountered no problems.
    * We have 1 shared integration / dev database. In order to make deployment to integration as quick as possible, we each link this to source control as "dedicated" then use the Get Latest tab to pull recent changes to integration. This has worked for us so far with no issues.

    The integration database is where we now have problems.

    * One of our users (myself) can work with it as usual, the rest get the above error when trying to get latest.
    * We tried creating a fresh database and linking this to source control. This works for the first person, but then fails for everyone else. If the original person unlinks then links again, it fails for them too.

    If there is any help you can give we'd be most grateful as we are pretty stuck with our existing workflow at this point.
  • James BJames B Posts: 1,124 Silver 4
    Could you ping an email to us ([email protected]) from the same email address you used to send the error reports through?
    We can then investigate.
    Systems Software Engineer

    Redgate Software

Sign In or Register to comment.