Socket failed to connect!?

bjbilicbjbilic Posts: 5
edited March 14, 2006 1:42PM in ANTS Load
Hi,

I tried to run sample ANTSLoadTutorialWebSite, but after successfully setting up the script, counters, and then running it, I get "15 virtual clients *FAILED", and in the section "Summary information by metric" subsection "Test Errors" I get the following message:
- Socket Failed To Connect 1
localhost An invalid argument was supplied 1

- Socket Failed To Read 4
An existing connection was forcibly closed by the remote host 1
Failed to read any information for http://localhost/ANTSLoadTutorialWebSite 3

- Failed To Process Request 1
Unhandled exception Input string was not in a correct format. 1

Like i said, site is running fine, I did record the script successfully, when edited in ANTS Editor, looks perfectly fine. I tried this with other sites I have and it always produces same error.

What is the problem? Any help is appreciated.

Regards, Bill.

Comments

  • Brian DonahueBrian Donahue Posts: 6,590 New member
    Hello Bill,

    I have a few questions for you. Have you got ANTS Load 1.7 or the older 1.5-1.6 versions? Secondly, had you changed the site back to Windows Authentication, and third, are you attempting to run these tests through a web proxy. In the third case the test probably will not work.
  • Thanks for your reply, Brian.

    1. I have ANTS Load 1.7 (BUILD 10)

    2. Authentication - most of the sites I am planning on testing use Forms Authentication. So, I have not changed your sample site back to Windows Authentication. Can you advise what to do work around this?

    3. Proxy - no, I have not used it knowingly. Does ANTS Load maybe switch this during the test, based on some settings. Your sample site and my other sites work fine (without proxy).

    Hope this will shed some light on my problem.

    Regards, Bill.
  • Brian DonahueBrian Donahue Posts: 6,590 New member
    Hello Bill,

    ANTS Load tests and recordings will simply not work through proxies. In the first case the WebClient can't open a request to a proxy and then make a request for a different resouce like a normal web browser can. In the second case, ANTS Load uses a proxy for script recording, which in turn can't go through via another proxy.

    Maybe this is a DNS /host file issue. Have you simply tries '127.0.0.1' in place of localhost and does your hosts file (%systemroot%\system32\drivers\etc\hosts) have an entry for localhost mapping to 127.0.0.1?
Sign In or Register to comment.