What are the challenges you face when working across database platforms? Take the survey

Config error only when running website under profiler

A.UserA.User Posts: 3
edited March 13, 2014 11:15AM in ANTS Memory Profiler 8
I'm currently trialling memory profiler to help identify and resolve suspected memory leak issues on a .net 2 site. When I first installed the trial it worked straightaway and gave some interesting results (somewhat stymied by the lack of any of our classes in the instance retention graph for the biggest culprits but that's an aside for now).

Trouble is, now the site doesn't work in the profiler and I'm not sure what's changed. The site executes fine in iis going to it outside of profiler. To start with I was getting a duplicate config section error - fair enough a section was in both machine.config and web.config but it worked fine before. I've gotten past this by removing that section in web.config, but now I'm getting unrecognized attribute 'targetFramework'.

This is present because the .net 2 site is making calls to a .net 4 authentication layer. The .net 4 layers run in their own sites with their own app pools set to .net 4 so I'm not sure why this error is occurring and why it didn't come up when I first installed the profiler.

Any thoughts?


  • Options
    I think the memory profiler may have got confused over which app pool it should be using (its using a .net 4 app pool).

    I'm quite confident this is related to changes in the config files.

    If you want things to "just work" again- I'd recommend starting from zero - its usually far quicker than full debugging- we can always do this later if, indeed, it ever arises again (plenty of things seem to sort themselves out on fresh deployments, in my experience). So deploy a fresh install of AMP on a different machine, make sure the web site is 100% working before profiling and retry profiling multiple times without changing anything. If it happens again- try and document the exact step that happened immediately before it not working. This will vastly reduce the time it takes to solve exactly why its happening. It could be several factors- as I say, I suspect the config files, but it could also be errant environment variable, file permissions and a few other things that would take a long time to trouble-shoot.
  • Options
    Thanks. I'll update this thread with any further information.
Sign In or Register to comment.