What are the challenges you face when working across database platforms? Take the survey
Options

Comparing 2008 R2 with Azure - Speed

bluebird84bluebird84 Posts: 10 New member
edited February 27, 2014 4:31AM in SQL Compare Previous Versions
Hi,

apologies if there is already another question regarding this, I've had a look but nothing obvious popped up in any searches of the forum. Also, if there's any additional information you require please let me know and I'll find out.

I'm running a Redgate SQL Compare (schema) between 2 databases: one is our Development DB (2008 R2 10.50.4276) and the other is our UAT DB (Azure 10.50.4021). The UAT DB is a Publisher in a replicated environment - there's no data being updated at the 2 subscribers at the moment, so there'll be very little if at all data being merged.

The issue I'm having is the time it is taking to compare the databases using SQL Compare (I've used version 7 and the latest version 10). Under the Registering Databases section, it takes a very long time for the Azure DB when 'Reading Object Text', around 15 minutes, before the comparison finishes.

Is this what I should expect when comparing a 2008 DB and an Azure DB? If not, is there any advice you can give to speed up this process (changes in any settings for the Azure DB for example).

again if you need further information please let me know.

many thanks

Comments

  • Options
    Hello,

    Thanks for your post.

    There shouldn't be any reason Azure takes longer to compare besides possibly network latency.

    One thing worth trying is to uncheck "Decrypt encrypted objects on 2005 and 2008 databases" in the options tab of the project screen in SQL Compare.

    Please let me know if that helps or if you have any further questions.

    Regards,
    Evan
    Evan Moss
    Product Support
    (866) 627-8107
  • Options
    bluebird84bluebird84 Posts: 10 New member
    Evan Moss wrote:
    Hello,

    Thanks for your post.

    There shouldn't be any reason Azure takes longer to compare besides possibly network latency.

    One thing worth trying is to uncheck "Decrypt encrypted objects on 2005 and 2008 databases" in the options tab of the project screen in SQL Compare.

    Please let me know if that helps or if you have any further questions.

    Regards,
    Evan

    Thank you Evan, unchecking the "Decrypt encrypted objects on 2005 and 2008 databases" option took the comparison time down to under 5 minutes.

    many thanks for your help
Sign In or Register to comment.