Generates 0x in script for empty blob type field

hrjkhrjk Posts: 4
edited May 27, 2016 6:44AM in MySQL Data Compare
MySQL Data Compare generates scripts with 0x for empty value for blob type field and when i run the script in MySQL workbench it throws this error "Error Code: 1054. Unknown column '0x' in 'field list'" error. How can I fix it or is it a bug?

Comments

  • Eddie DEddie D Posts: 1,489 Rose Gold 3
    Thank you for your forum post.

    This is an error I personally not seen before. Is the cause of the error due to the '0x' only having single quotation marks surrounding it where it needs two single quotation marks, ''0x'', as per this internet ARTCLE?

    If the answer is yes, I will need to submit a bug report.

    A support call has been created for you HERE. Would it be possible to obtain a CREATE TABLE syntax for us to attempt a reproduction? Please either update the support call or reply to this forum post.

    Many Thanks
    Eddie
    Eddie Davis
    Product Support Engineer
    Redgate Software Ltd
    Email: [email protected]
  • No it generates script without any quotation mark like shown below:
    INSERT INTO tablename VALUES (0x, 0x, 'testabc');
    

    But if the blob field is not empty then it generates hex value without quotation mark and that works fine but only for empty value it generates script like above and when I run that script it throws error.
  • If you can generate script like below for empty blob field then that should work:
    INSERT INTO tablename VALUES ('', '', 'testabc');
    
  • Eddie DEddie D Posts: 1,489 Rose Gold 3
    Thank you for your reply.

    With the further information you have provided, I am able to reproduce this problem. Therefore I have submitted a Bug Report for the Product manager and Development Team to consider. The Bug Report reference is MSDC-33.

    Now for the bad news, sadly I do not know when this bug will be fixed. I will be maintaining what our bug tracking system calls a 'watch' on the report submitted, which means I can update when a fix for the problem becomes available.

    Thank you for bringing this error to our attention.

    Many Thanks
    Eddie
    Eddie Davis
    Product Support Engineer
    Redgate Software Ltd
    Email: [email protected]
  • Eddie DEddie D Posts: 1,489 Rose Gold 3
    Hi

    I am please to infrom you that this bug is now fixed in V1.0.0.712 of mySQLDataCompare which can be downloaded using this LINK.

    Please do download and upgrade to confirm that the bug is fixed in your environment.

    Many Thanks
    Eddie
    Eddie Davis
    Product Support Engineer
    Redgate Software Ltd
    Email: [email protected]
Sign In or Register to comment.