What are the challenges you face when working across database platforms? Take the survey

extra object (schema) when comparing source control to a DB

ajmudrak@rutgers.eduajmudrak@rutgers.edu Posts: 2 New member
edited December 4, 2014 11:18AM in SQL Compare Previous Versions
When performing a SQL Data Compare between a database I have in SQL Source Control and a live database, there is an extra object appearing in the Source Control version that actually does not exist. The extra object is a schema for a user that was not included in source control (filtered).

On the database that is linked to source control, the schema itself doesn't even exist. The user that it belonged to does, but that user account is filtered from source control, and was never committed.

On the destination live database I'm trying to copy the schema to, the schema doesn't exist, and it shouldn't.

When I checked out the source control copy of the database to a folder, and searched through the .SQL scripts, I couldn't find anything in there that included this schema.

Do you know why it might think that the schema exists and is trying to add it to my live destination database?




  • Options
    Anu DAnu D Posts: 876 Silver 3
    We have logged a support ticket for you and will email you shortly.
    Anuradha Deshpande
    Product Support
    Redgate Software Ltd.
    E-mail: support@red-gate.com
  • Options
    Brian DonahueBrian Donahue Posts: 6,590 Bronze 1
    Might be some backward-compatibility issue with SQL 2000, because back then schemas did not exist and were the same as users. I seem to recall some older versions of SQL Compare made a schema for a user when going from 2000 to 2005. (of course these days SQL 2000 support has been dropped entirely so I don't think the latest version would do that).

    It's also possible that there is some object either owned by or has permissions set for that schema and it's being created as a dependency.
  • Options
    Was there a solution for this?

    I am having the same issue described above.
Sign In or Register to comment.