What are the challenges you face when working across database platforms? Take the survey
Options

SQL Prompt insert TAB,Space, Enter ????

mario17mario17 Posts: 15
edited January 24, 2014 2:55PM in SQL Prompt
Hi,

I see that Enter is working different when I select from menu, it insert column name from list + rightmost characters of this name from the current position

To reproduce:
1. start select... from your_table
2. start typing column name let say 'ben..'
3. menu pop ups with available choices
benefit_id
benefit_name
benefit_alt
sp_your_ben1000

4. Down error select on benefit_name
5. ENTER
..see benefit_name inserted on edit screen
..list change a look

** now I know just get way from SQL Prompt

6. ENTER (again)
.. <benefit_nameefit_name> that what I have now????!!!!!!

#6 could be replicated also with TAB as well.

On my option I have in SUggetsion/BEhavior/Insertion Keys
Enter checked ON
TAB checked ON
Space bar ... nothing (OFF)

Is that normal? What I'm missing?????

Thanks
Mario

Comments

  • Options
    Aaron LAaron L Posts: 596 New member
    Hi Mario,

    It sounds like you've got the built in intellisense as well as Prompt enabled. You can disable the built in intellisense popping up by going to Tools->Options->Text Editor->Transact-SQL and unticking Auto list members and Parameter information.

    Another user has reported the same issue so I think our installer might not be disabling it in all cases. Can I ask which version of SSMS you are currently running?

    Thanks,
    Aaron.
  • Options
    Hi Mario,

    I searched the forums because i had a similar issue. I found the problem for me under SQL Prompt - Options -> Suggestions > Behavior > Insertion keys section. I had nothing checked for the insertion trigger here. In this section, one can select which key to press to trigger the insertion from the Suggestion dropdown. Once i checked the key press to use (i chose Space bar) then the insertion action worked. Hope this helps.

    Kind regards,
    Randy Sullivan
  • Options
    To answer and add to Aaron's post, I did notices the same behaviour as the one he answered to and I aplied his fix... it worked but I had to restart SSMS.

    My version of SSMS is 10.50.1600.1 and Prompt SQL is 6.2.0.366.

    Hope it helps,
    George.
Sign In or Register to comment.