What are the challenges you face when working across database platforms? Take the survey
Options

Comparing against Snapshot causes an error

montymonty Posts: 6
edited February 28, 2006 5:16AM in SQL Compare Previous Versions
When you create a snapshot through the SQLCompare utility then attempt to compare an actual databases against it (again through the SQLCompare utility), it throws the exception, "Object reference not set to an instance of an object."

I've also tried it using the API and the following exception information is shown:
************** Exception Text **************
System.NullReferenceException: Object reference not set to an instance of an object.
at RedGate.SQLCompare.Engine.Permissions._1()
at RedGate.SQLCompare.Engine.Permissions._1(Permissions , Options )
at RedGate.SQLCompare.Engine.UserDefinedType.Equals(IDatabaseObject target, Options options)
at RedGate.SQLCompare.Engine.Database._1(Differences , IDatabaseObjects , IDatabaseObjects , Options , Int32 , Int64 , Int64& , Int32& )
at RedGate.SQLCompare.Engine.Database.CompareWith(Database targetDatabase, Options options)
...

I've tried regenerating the snapshots and also getting a snapshot of different databases, but all return the same error.

After further investigation it appears that a database snapshot without our custom boolean type (boolean:bit) does not cause this error.

SQLCompare version: 4.1.0.59 (evaluation)
.NET 2.0

Any help greatly appreciated. Please let me know if you require any more info.

thanks
Mark

Comments

Sign In or Register to comment.