SVN - Auto-properties not applying correctly

JasonNKyleJasonNKyle Posts: 2
I am attempting to link my database in SQL Server 2008r2 to our existing SVN repo in a new folder.

However, I get an error on some objects that "xxxx.sql has inconsistent newlines". I am aware this is a known issue with using the eol-style tag in SVN.

I have set my config file (for SVN) to not set that property for SQL files, and can commit these files if I do them manually. But, SQL Source Control is still generating the error.

I have checked the property setting in the following locations:
- My workingbase folder
- The actual repository
- My local automatic settings

They are all "correct" in that they do not set an EOL property. However, when I commit a single object for a test, it shows up with the EOL propertyset. Is this a setting in SQL Source Control somewhere?


  • Thanks for your post- I checked our bugtracker, and this kind of message has come up previously, although only very occasionally.

    One user observed that they fixed it with the following process:
    Problem occoured on an initial commit from my database to an empty source control location. I've figured it out - problem was caused by SVN settings located in %APPDATA%\Subversion\config file. 'enable-auto-props' setting was set to 'yes'. Changing it to 'no' solved my problem.

    Could you maybe see if that helps in your case? We don't expose the actual setting anywhere (we use the SharpSVN library, which I believe should honour whatever is configured locally via Tortoise etc.)
    Systems Software Engineer

    Redgate Software

Sign In or Register to comment.