RgPublish Error

SteveGTRSteveGTR Posts: 91
edited October 11, 2013 10:37AM in Deployment Manager
I'm in the process of testing the deployment capabilities to our development database/website. Initially, this process will be manual until we can settle on an automated method (suggestions welcomed).

Was able to deploy the database using the SSMS deployment plug-in tool without a problem. Now on to the website.

We are still using Visual Studio 2008 (TFS repository) for our website. Hence, there is no project file (csproj) for the Visual Studio deployment plug-in to reference.

I used the RGPublish tool and the folder option to attempt to load the package to the nuget feed on our deployment manager. The command line looks like this:

RgPublish /source="C:\projects\tfs page merge\webpage" /version=1.0 /packageid=RGPublishTest /target=feed:http://eerepagedevweb1:8080/nuget/

The processing goes fine past the "Writing package..." stage, but chokes during the "Publishing package to feed at http://eerepagedevweb1:8080/nuget/..." stage with the following error:

"Unable to write data to the transport connection: An operation on a socket could not be performed because the system lacked sufficient buffer space or because a queue was full."

I was able to package sub-directories of the project using the above command, so the feed is working.

Here is the statistic on the webpage files:

Files: 4535
Directories: 289
Size: 217,287,296 bytes
Size on disk: 229,191,680 bytes

I looked at the nuget/web.config file and saw where you allow up to 4GB for file sizes. I monitored the RGPublish processing and estimate it is writing out a package of 168,034,304 bytes.


  • Hi Steve,

    The 4Gb limit should be fine; but we do see errors sometimes with large-ish packages. One user reported issues when their packages were ~400MB in size, but the problem stopped happening when it was down to around 100MB. I think they got a different error to the one you're seeing though.

    Googling it, it seems that one possible cause is port exhaustion, which can be helped by amending a registry key - see here
    Systems Software Engineer

    Redgate Software

  • Thanks for the quick reply James. I tried that and it still doesn't help. The same error occurs.
  • It may well just be the built in feed not handling the larger packages for some reason. Have you tried configuring a standalone feed to see if it's more effective? See http://documentation.red-gate.com/displ ... ackagefeed
    Systems Software Engineer

    Redgate Software

  • You know I didn't configure this setting on both machines. I only did it on the server. I'll try it again after I've reconfigured the other computer and report back. Thanks again :)
  • Well my idea didn't work. The same error is generated. I'll look at what you posted.
  • While looking at the link on creating the nuget feed it struck me that I could just have RgPublish put the nuget package directly on the deployment manager server.

    I changed the command to:

    RgPublish /source="C:\projects\tfs page merge\webpage" /version= /packageid=WebPage /target="\\eerepagedevweb1\c$\ProgramData\Red Gate\DeploymentManager\Data\feed"

    Viola!!! The process worked and the package is available for publishing. For the record here are the details of the package that was choking the nuget feed:

    138,135,459 WebPage.

    Thanks for your help James, I appreciated it :)
  • Ah, cool - glad to hear you've worked around the problem!
    Systems Software Engineer

    Redgate Software

Sign In or Register to comment.