Deployment Manager over SSL, DNS and Port 443

dcoyledcoyle Posts: 6
edited January 31, 2014 4:41AM in Deployment Manager

I've been trying to get Deployment Manager to run over SSL Port 443 and a custom DNS address such as:

I've made the normal changes in IIS fine and the WebApp seems to run fine. I can also connect to the server from the VS studio plugin - however when I try to Publish a Package via the Visual Studio plugin it times-out. In each case it seems to want to resolve the address back to the servers name and http running on port 443 i.e:


1.) Can I do what I am trying to do?
2.) how do I modify the internal DNS name that Deployment Manager keeps using.



  • Hello,
    Yes Deployment manager should work in this situation although it is not something that we officially support.

    I believe that you are trying to publish to the embedded nuget feed that is installed with Deployment Manager. To do this you will need to change a registry key value, using regedit.exe. You will need to change the value of the EmbeddedNuGetUri String value key in [HKEY_LOCAL_MACHINE\SOFTWARE\Red Gate\Deployment Manager] to and then restart the Red Gate Deployment Manager service in Services.msc.

    The Visual Studio plugin asks Deployment Manager for the list of feeds, which it obtains from the information stored on the Package feeds page. You may also need to change the value listed here to match the value that you put in the registry although the service restart should do this. The Package feeds page can be accessed via the Settings tab.

    Please be aware that if you run the Server Tools application, this will reset the bindings of your deployment manager server and the embedded Nuget feed.

    Hope that helps.
  • Thanks that worked great.

    Given changes in last version for including Windows Authentication it would also be great if access to NuGet Feed also required this security.

    Thanks again.
  • This fix does not seem to be working for me. I edit the value of the EmbeddedNuGetUri String to https but something is forcing it back to http whenever the web site is restarted.
    Also in Server Tools, the port updates to 443 but the URI will always stay at http:
    I'm able to get to the site if I manually type in https://deploy.....
    Has anyone out there seen this when trying to setup the web site to use SSL, port 443?
  • Can I just check that you remembered to restart the Windows service (Red Gate Deployment Manager) after changing the registry value, not the web site?
    Development Lead
    Redgate Software
  • Thanks Mike, you were right I missed the service restart. The registry value has saved correctly with https.
    Any idea about the other thing with the URI on the server tools staying with http?
  • I'm glad that's fixed it for you. The Server tools app shows 'http' because it doesn't understand the HTTPS configuration (we don't officially support this configuration yet), but that shouldn't affect anything else, as long as you don't use it to change the port.

    We do intend to make HTTPS a properly supported configuration at some point.
    Development Lead
    Redgate Software
Sign In or Register to comment.