Error loading package <pkgname>: Collection was modified...

dwainewdwainew Posts: 56 Bronze 3
edited March 13, 2006 8:20AM in DTS Package Compare 2
I'm getting MANY of these errors:

Message: Error loading package <pkgname>: Collection was modified; enumeration operation may not execute.

Category: Application

Description: not going to bother, the message report screen needs a "copy" command...

These errors result in the package showing as "cannot be compared"

Comments

  • dwainewdwainew Posts: 56 Bronze 3
    In addition, clicking on any server version of any of these packages shows an error icon in the main pane of the app and no details, only the versiod drop down and the following:

    This package cannot be compared;
    problems occurred whilst loading it.

    following the link there I see the description of the error:
    Error loading package '_Import File APSVW1VS' : Collection was modified; enumeration operation may not execute.

    at _22._8()
    at _22._10()
    at _22.Compare()
    at RedGate.DtsCompare.Comparison.ComparisonFactory.CompareAndExpose(IPackageVersion version1, IPackageVersion version2)
    at _37._1(_64 , IPackageVersion , _64 , IPackageVersion , _89 )
    at _37._9(_28 )
  • Brian DonahueBrian Donahue Posts: 6,590 New member
    Hello Dwaine,

    I've emailed you privately about this. Please let me know if you don't get my response.

    Thanks!
  • dwainewdwainew Posts: 56 Bronze 3
    Brian,

    :? Waiting to hear some news regarding the errors I found with DTS Package Compare 2. Any progress? I'd really like to hear what your dev team has found and how long it will take to overcome.

    Please don't take this personally. In fact, I'm really confused as to how to react because every person I've communicated with at red-gate has just been as nice as possible, including yourself. Unfortunately, I'm damn mad at red-gate as a company. DTS Compare has been entirely worthless from day one. After almost 2 years of waiting for a usable version of this tool, I'm EXTREEMLY disappointed that the 2.0 release wasn't ready for prime time. I requested to be included in the Beta testing of this tool WAY back when, and was denied. And yet, there's now an error generated when processing my packages that were available for you to test before 2.0 development even started! I'm just curious if red-gate has a comment on that fact?

    In the future, red-gate should probably consider soliciting Beta testers more carefully. The trick with testing is not picking those that will use your product once or twice against a limited array of test objects and give you smiley faces because of the pretty interface. The powers-that-be may have been annoyed at me for being one of the most outspoken posters regarding the previous version's performance, but maybe that would have been the very reason to allow (or maybe even ASK) me to Beta test your new version! I use HUNDREDS of DTS packages to import GIGABYTES of data per night from mainframe, Lotus Notes, DB2, etc. I have needed this tool for YEARS. Now I'm STILL waiting...........:roll:
  • Brian DonahueBrian Donahue Posts: 6,590 New member
    Hello Dewaine,

    I'm aware you were dealing with one of our programmers by email. He is away today, but will be back on Monday. I'll see if I can find the status of this from him at that time.

    Thanks for your patience.
  • dwainewdwainew Posts: 56 Bronze 3
    Brian,

    Thanks for the speedy reply.

    As far as i can remember, you're the only one I've communicated with regarding this issue.

    When I sent the packages you requested, I kind of expected a response, from the recipeint, but got none. That's why I followed up to you afterwards to make sure you didn't need anything else.

    Thanks,
    Dwaine
  • Brian DonahueBrian Donahue Posts: 6,590 New member
    Hello Dwaine,

    I've just emailed you a patch to DTS Compare. Please let me know if you don't get it! Again, sorry for the delay.
This discussion has been closed.