Command Line Switch AddDatabaseUseStatement Not Working

CraigEddyCraigEddy Posts: 36 Bronze 3
edited August 5, 2013 1:11PM in SQL Compare Previous Versions
I've added this to the command line, but my script doesn't have the USE statement. Here's a snippet from the powershell script that executes my comparison:

sql_compare /Database1:FACTSInfo /Version1:Head /Database2:FACTSInfo /Server1:$sqlServer /Server2:$sqlServer /filter:$filterfile /options:IgnoreWhiteSpace,IgnoreFillFactor,AddDatabaseUseStatement /sync /scriptfile:deploy.sql /force

I'm comparing from SQL Source Control to a newly-restored copy of the database, which is why the same database name is used.

Any ideas?

Craig Eddy


  • Thank you for reporting this.
    I was able to reproduce the behavior you are describing and have logged a bug in our system under the internal reference number of SC-6479.
    Sorry for any inconvenience this may have caused.
    Manfred Castro
    Product Support
    Red Gate Software
Sign In or Register to comment.