Competition: What’s your favorite Redgate tool? Enter now.

SQL Search has stopped indexing stored procedures &functions

georhillgeorhill Posts: 20
edited July 2, 2013 2:24PM in SQL Search Previous Versions
I noticed that SQL Search was not returning all stored procedures that had certain words in them (for example, the word "daily") because I had just changed a bunch of them and added that word.

I tried refresh and force reindex without success. Based on another post, I deleted the index file for the one database that was having the problem.

Unfortunately this caused SQL Search to blow up when I tried to search, reindex or force index on that database. I got around this by copying and renaming a different index file for a database with the same schema.

SQL Search still does not appear to be indexing the contents of stored procedures in this database. Any workarounds or suggestions appreciated.

Comments

  • I don't know exactly what you mean by "blow up", but if SQL Server Management Studio was running when you deleted the cache files, then SQL Search will throw errors like "SQLite error: no such table: syscomments" and "SQLite error: no such table: meta", even after you restart SSMS.
Sign In or Register to comment.