Spins infinitely Retrieving schema and Registering Databases

rvaiyapurirvaiyapuri Posts: 5
edited September 16, 2013 4:20AM in SQL Data Compare Previous Versions
I have a requirement like this -

I have a production database on which I have 5 major views which need to be compared against the same kind (same view structure) in the development environment.

I tried to retrieve the schema and it just keeps on spinning and I see no progress. Please let me know if the database schema are different, can't we compare specific tables and views alone with SQL Data Compare?

Please help!

Comments

  • James BJames B Posts: 1,124 Silver 4
    Hi,

    There's no obvious reason why it would get stuck reading the schema, but there's a couple of things to try:

    - firstly, ensure you're connecting using an account with sysadmin permissions to eliminate any security problems.

    - if that doesn't help, can you try SQL Compare- does that successfully read the schema or does it get stuck/crash?
    Systems Software Engineer

    Redgate Software

  • I tried using SQL compare and it gets stuck there as well.
  • We'd probably need to see the database to understand why. is it possible to obtain a backup? If so, you can mail to [email protected] quoting F0071697 in the subject line.
    Systems Software Engineer

    Redgate Software

  • @rvaiyapuri,

    I also experienced this and was able to resolve this issue by creating a new project. My project had other symptoms of corruption, maybe your project has only a minor corruption causing this. Try creating a new project and see if it loads more quickly.

    Best,
    Scott
  • Just to add to the post, I had the same issue. Turned out a colleague had restored the test database and wiped out my access. So, SQL Data Compare could not access the database. I needed to refresh the Logins in SQL Management Studio to see that I was no longer a user. Might also have helped if SQL Data Compare pointed this out too. Now a little bit wiser.
    Robin Humberstone
Sign In or Register to comment.