SQL Compare command line not working on build machine

XaphanXaphan Posts: 18
edited April 29, 2013 5:22PM in SQL Compare Previous Versions
I was able to get SQL Compare to work with the following command line on my personal workstation:
"C:\Program Files (x86)\Red Gate\SQL Compare 10\sqlcompare.exe" /sourcecontrol1 /revision1:HEAD /s2:MyDatabaseServer /db2:MyDatabaseName /o:Default /Include:identical /sfx:Automated.xml /sync

Automated.xml was located in the directory that I ran the command line from. I tried this again on my build server using the exact same command and got the following error:

Error: The file 'Automated.xml' containing the script folder location XML fragment could not be parsed. Check that the file exists and that its contents are well-formed.

My build server has both SQL Compare and SQL Source Control installed and they are both in the same version as on my workstation. The Automated.xml is also located in the directory where I am calling the the command line from on the build server.

I should also note that SQL command line normally does work on my build server. It just only give me this error when I'm trying to read from an XML file to get the script file location in source control (which is what I want to do here).

Why is my workstation running the command prompt without errors, but the exact same command is giving me error on my build machine? Does my build machine need something installed or setup in order to make it work?


  • Thanks for your post. It could be an issue with the actual contents of the xml file and the way it is formatted. Are you using the same exact xml file between the two machines?

    We have opened a support ticket and will be contacting you shortly.

    Best Regards,
    Steve Tanori
    Product Support
    Red Gate Software Ltd.
  • I have confirmed that the XML is the exactly the same on both machines. Here is the contents of the XML file (I changed the names of the actual servers since this is a public forum):
    <?xml version="1.0" encoding="utf-16" standalone="yes"?>
    <ISOCCompareLocation version="1" type="TfsLocation">
  • Red Gate's staff helped me fix this. It turned out that SQL Source Control had to be re-installed on the build machine. After I did that everything worked like a charm.
Sign In or Register to comment.