Ignore ROWGUID column?

lund0529lund0529 Posts: 9
edited December 29, 2005 12:45PM in SQL Data Compare Previous Versions
Hello - I have two datbases that are the same except for they ROWGUID replication column. Is there a way to exclude this column from the comparison?

I know I have a handful of records that need to be synchronized between the two databases, but they're each in their own replication cycle and have unique GUIDs on each record. Because of this, every record shows up as different between the two databases, even though the only difference in 99% of them is the ROWGUID.

Thanks Much,
lund0529

Comments

  • Brian DonahueBrian Donahue Posts: 6,590 New member
    Hello there,

    There is already an option available from the comparison->options menu to ignore ROWGUID columns. If this is off, then Data Compare will show you the values of the ROWGUID columns in the results, but these columns can never be synchronized, even if you wanted to.
  • The Comparison-->Options I have, and whether they are checked or not, are as follows. These haven't been changed from the defaults. I'm on SDC v3.4.0.8.

    [X] Disable Foreign Keys
    [ ] Disable Triggers
    [ ] Drop primary keys, indexes and unique constraints
    [X] Include timestamp columns
    [ ] Do not use transactions
    [ ] Exclude IDENTITY columns
    [ ] Trim trailing spaces

    Nothing about ROWGUID. I went through on the wizard and unchecked each of the rowguid columns from the tables before the compare.

    This fixed the compare, but I'm unable to sync the rest of the data. i.e. keep the rowguid, but update the names, phone numbers, etc.

    I think I can probably gut the script and take out all the rowguid references from the statements, but is there another option?
  • Nevermind, I unchecked the column next to ROWGUID in one table. With that corrected, the sync worked as expected.

    Thanks!
  • Brian DonahueBrian Donahue Posts: 6,590 New member
    Sorry I got ROWGUID confused with timestamp...
This discussion has been closed.