Problems using Framework 2.0

jordyjordy Posts: 2
edited February 3, 2006 6:33AM in ANTS Load
Hello,

We've been using ANTS Load with .NET 2.0 with no problems, until we want to use Webservices. When using webservices it can't create the proxy object correctly. By placing an other WSDL version into the ANTS Load dir, it is fixed and we can create a test case using the Wrapper.

When running the test, the proxy wrapper raises errors. That the object reference is not set. So could someone explain how we can setup ANTS to work with the latest .NET 2.0 (It's been final for some time now).

Another problem is that when running the IIS in Framework 2.0 (.NET) the SESSIONS doesn't work in ANTS Load. You'll have to switch to 1.1 before it works.


Thx in andvance

Jordy

Comments

  • Brian DonahueBrian Donahue Posts: 6,590 New member
    Hello Jordy,

    I'd wager that the culprit behind the webservice failure is not the fact that it's running on Framework 2.0, but rather that the webservice uses Web Service Extensions. If ANTS Load can't create a proxy wrapper, then it's because of WSE almost all of the time. Unfortunately ANTS Load simply doesn't support WSE.

    The only other issue I'm aware of with .NET 2.0 is the new HttpOnly cookie, which is a switch rather than the expected name/value pair. We have a patch available for that particular problem if you would like to send an email to [email protected] and request it.

    I'm afraid there isn't anything we can do if you're referencing WSE in your webservices, though. Sorry!
  • I am having the same issues with .NET 2.0

    I do NOT have WSE enabled for the web services.

    Is there going to be a new release/fix to allow support for .NET 2.0 ?

    Thanks
  • Brian DonahueBrian Donahue Posts: 6,590 New member
    We're working on it.
  • Hi there,

    the version of wsdl in the ANTS Load directory is from the .NET 1.0 SDK. You should update it to the version from .NET 1.1 SDK - we will be fixing this in ANTS Load 1.70 coming soon. I have verified that I can load test a simple ASP.NET 2.0 web service with this version of wsdl.exe.

    Let me know if this works,

    Tom Harris

    Red Gate Software Ltd
  • Thanks Tom.

    This has fixed the issue.

    When is the next version of ANTS Load due for release?

    Ash
  • Hi there,

    we have fixed the bug where session state id is not being correctly tracked on ASP.NET 2.0. This fix will be part of ANTS Load 1.70. ANTS Load 1.70 will be released in February 2006.

    Many thanks,

    Tom Harris

    Red Gate Software Ltd
Sign In or Register to comment.