VDI error 1000 on all backups using SP

jduckworthjduckworth Posts: 4
edited January 9, 2006 8:24PM in SQL Backup Previous Versions
The backups work fine through the program interface but when I run the backups through QA using the stored procedure it consistently gets this message
VDI error 1000: Failed to create virtual device. Check that the SQL Server instance you are trying to connect to is running. E

The server is locked down and windows authentication has been disabled some how. I imagine this has something to do with it. Please help. Also how can we activate the software on a server that has no internet connection?

Thank you in advance, Joel Duckworth

Comments

  • Brian DonahueBrian Donahue Posts: 6,590 New member
    Hello Joel,

    When you run SQL Backup through the UI, what account do you use? It could be possible that you need to connect using this same information in Query Analyzer, and possibly also specify this information in the backup command at the end if you're using SQL authentication or the SA account, for example
    exec master..sqlbackup '-SQL "backup database [northwind] to disk=[c:\temp.sqb]" -U sa -P <password>
    

    If you cannot activate SQL Backup over the Internet, you can use the activate by email option. This way you can copy the actual request data, paste it onto a floppy, attach it to an email and send it to [email protected]. You should leave the software open until you get the response email from us so you can paste that into the software to activate it.
  • yes, I have tried both authentication methods in the script, and both seem to give the same result. We are connecting via SQL authentication (using the sa account) through the UI, windows authentication is disabled on the server and doesn't work in the UI. Any more ideas?

    Also, we have set the SQL Sever service to use a particular user account, not the system account. Have other people had issues with non standard settings of which I might be able to check for?

    Thank you, Joel
  • Brian DonahueBrian Donahue Posts: 6,590 New member
    Hello,

    The only things that the SQL Server account will affect are
    • The location where SQL Backup writes temporary files
    • Access to the activity logs folder
    The temp files are in that user's profile, but maybe you'll want to make sure that the SQL Server service account can write to %allusersprofile%\Application Data\Red Gate\SQL Backup\Logs (and data). As far as I'm aware, missing rights to these folders should cause a VDI 1010 error rather than a VDI 1000 error. 1000 indicates that a virtual device can't be created for SQL Backup to use.
  • I have checked the file permissions as suggested and we are still having the same problem (see below for logs). The server is running on a non standard port as well. Can we please have some more suggestions asap to try and fix this issue?

    1/10/2006 9:26:25 AM: SQL Backup 3.2.0, (c) Red Gate Software Ltd 2004 - 2005
    1/10/2006 9:26:25 AM:
    1/10/2006 9:26:25 AM: Backing up prod_gp_live (full database) to E:\SQLBackups\\prod_gp_live_20060110_092625.sqb ...
    1/10/2006 9:26:25 AM:
    1/10/2006 9:26:25 AM: BACKUP DATABASE [prod_gp_live] TO DISK = 'E:\SQLBackups\\prod_gp_live_20060110_092625.sqb' WITH NAME = 'prod_gp_live 10-Jan-06 09:26:25', DESCRIPTION = 'Backup on 10-Jan-06 09:26:25 Database: prod_gp_live', INIT, PASSWORD = 'XXXXXXXXXX', ERASEFILES = 7, COMPRESSION = 3
    1/10/2006 9:26:25 AM:
    1/10/2006 9:26:28 AM: VDI error 1000: Failed to create virtual device. Check that the SQL Server instance you are trying to connect to is running. Error code: -2139684859 (Failed to create security environment.)
  • peteypetey Posts: 2,358 New member
    Does the SQL Server service startup account have administrator rights to the SQL Server instance?

    If possible, I would try starting the SQL Server service using the LocalSystem account, and run a simple backup via QA, to check if access is an issue.
    Peter Yeoh
    SQL Backup Consultant Developer
    Associate, Yohz Software
    Beyond compression - SQL Backup goodies under the hood, updated for version 8
Sign In or Register to comment.