What are the challenges you face when working across database platforms? Take the survey

Object Level Recovery error

ScottDuncanScottDuncan Posts: 4
edited March 25, 2013 3:15PM in SQL Backup Previous Versions
I have just been trialing SQL Backup Pro (after being advised HyperBac was being discontinued) and came across an error while trying to restore a table via Object Level Recovery:
Unhandled Exception
System.IndexOutOfRangeException occured:
Index was outside the bounds oF the array.
at kk.a(Int32)
at kl.a(jV,lc)
at ku.GetDataStream()
at ku.get_Data()
at ks.b()
at kP.a(String, IEnumerable`1 , IEnumerable`1)
at kP.PopulateTable(dY name, lc pageProvider, kH schemaProvider, jE tracker)
at hT.a(List`1)
at hQ.PopulateAdditionalSystemTables(dY[] tables)
at h.a(Int32)
at W.l()
at W.GetSqlCmd(Int32 view)
at h.a(Int32)
at K.b()
at K.RedGate.ObjectLevelRecovery.Engine.CTB.ISCSimplePopulator.get_Sql()
at G.<EnumObjects>d__0.MoveNext()
at u.Read()
at w.Read()
at b.a(aM)
at b.a(aM)
at bC.a(aM)
at bc<>c_DisplayClassf,<ObjectsTreeViewAfterSelect>b__c(Object param0)
at System.Threading._ThreadPoolWaitCallback.WaitCallback_Context(Object state)
at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state)
at System.Threading._ThreadPoolWaitCallback.PerformWaitCallback(Object state)

I wasn't even doing anything tricky. Trying to restore a 5 row table from database A backup into database B. Disk/database free space not an issue. Tried with compressed+encrypted, compressed+no encryption, and no compression+no encryption backups. The table was in the dbo schema, so no issue with missing schema. The table is not using user-defined data types. It's about as simple as it gets.

SQL Server 2005 SP4 (9.0.5000)
.NET 2 (v2.0.50727)
Windows 2003 R2 SP2 Std Edition x86 on VMware

Ideas? More info required?



  • Options
    I am the support engineer that is responding to this request. OLR has a few limitations and it seems like you are running into the issues. I am sorry and want to apologise for the trouble this has caused on your side.

    Just to get a more understanding of the situation are you able to let me know the following:

    1) Location of the backup?
    2) The size of the backup file?
    3) The size of the database when online in sql server?

    I know you have said that it's just a five row table. Just wanted to confirm the above to be sure! Apologies for repeating this!

    Also let me now if the source and the destination server for the backup is this same server? or it was taken on a different server?

    One possible reason for this could be the version of .Net on this server? Are you able to try this on a machine with version 3.5 and above?

    We welcome your business and look forward to hearing about your experience with this tool.

    Thanks for your patience and feedback in this matter.
  • Options
    It worked fine with a database backup that contained about 2.5GB data.

    After creating a new backup of the smaller database, it's behaving itself. I have noticed that using the backup that wasn't working, only stored procedures and tables were showing as being available to restore. In the newer backup, views are shown as well.

    I've just now tried again and got it to fail again on the first server with the original database. It seems to be the CHECKSUM setting - when I turn it off, I can do OLR (and views are in the list of objects able to be restored. The 2.5GB database I used as above must've been backed up with CHECKSUM off, to save a bit of time on my slow DEV system - which threw me when OLR started working). Having all other settings the same, when I turn CHECKSUM on, views disappear from the list of recoverable objects and I get the error message reported when I try and restore any of the tables. A full restore of the database (to a different database name at least) works fine.

    I tried backing up the bigger databases with CHECKSUM enabled and doing OLR. The first one I tried gave me this error: "Unable to get PFS page for page ID 1:198668" after 50% through importing schema information.

    Same error (different page) for another DB I tried (that previously worked when CHECKSUM was not enabled).

    Both machines are x86 Windows 2003 R2 Standard Edition with SP2. 1GB RAM, single 2.3Ghz CPU.
    Both machines are running SQL Server 2005 Developer Edition with SP4.
    Both are VMWare virtual machines on VMWare 5.0.

    I tried with x64 SQL 2012 on x64 Windows 2008 R2 Standard Edition SP1 - I get "Unknown database compatibility version 110" error message (regardless of CHECKSUM setting).

    I tried with x64 SQL Server 2008 R2 Standard Edition with SP2 on x64 Windows 2008 R2 Standard Edition (no SP). With CHECKSUM on, I got the following error: "Error reading backup objects: Couldn't locate entry for HoBT {34,1} in allocations table". With CHECKSUM off, OLR worked.
  • Options
    SQL Backup 7.3 doesn't seem to have fixed the issue. :o(
  • Options
    Mike_Vessey77Mike_Vessey77 Posts: 7 New member
    Its still an issue in backup 10 and compare 13
Sign In or Register to comment.