Issue Linking database to https://[yourco]

EWhitlowEWhitlow Posts: 10
I have been trying to link a database to hosted TFS.

I have applied the most recent updates.

Using SSMS 2012 v11.0.3000.0

I made the changes to the config file and now I can get to the login page during the link attempt while trying to set the database folder, after entering the correct username and password (verified it twice) I get incorrect username and password. But when using the same username and password I have no problem accessing the website. I have also tried alternate credentials.

The error is eventually:
System.Security.Authentication.InvalidCredentialException: TF30064: You are not authorized to access the server. ---> System.Security.Authentication.InvalidCredentialException: TF30064: You are not authorized to access the server. ---> Microsoft.TeamFoundation.TeamFoundationAuthenticationRedirectionException: TF30064: You are not authorized to access the server.
at Microsoft.TeamFoundation.Client.TfsConnection.ThrowAuthorizationException(Exception e)
at Microsoft.TeamFoundation.Client.TfsConnection.UseCredentialsProviderOnFailure(Action action, Int32 retries, Boolean throwOnFailure)
at Microsoft.TeamFoundation.Client.TfsConnection.EnsureAuthenticated()
at #oLi.#fqi.#A2.#gqi()
at #oLi.#uRi.#LBf(#ovB #Moi, Action #sxPb, Boolean #Nesc)
--- End of inner exception stack trace ---
at #oLi.#uRi.#LBf(#ovB #Moi, Action #sxPb, Boolean #Nesc)
at #oLi.#uRi.#LBf(VersionControlServer , Action )
at #oLi.#fqi.#Ipg(ICancellableOperationStatus , IReadOnlySourceControlServerCallBacks , Action , TfsLocation , ICredentialsStore , #Fqi , VersionControlServer , Object )
at RedGate.SQLSourceControl.Engine.SrcC.TFS.Shared.TfsRemoteOperations.#Ipg(ICancellableOperationStatus , IReadOnlySourceControlServerCallBacks , Action )
at RedGate.SQLSourceControl.Engine.SrcC.TFS.Shared.TfsRemoteOperations.#oY7(ICancellableOperationStatus , String , IReadOnlySourceControlServerCallBacks )
at #Zgob.#0gob.DoRefresh()
at RedGate.SQLSourceControl.RepositoryBrowser.VirtualTreeNodes.VirtualTreeNode.Refresh(NodeRefreshed onComplete)
--- End of inner exception stack trace ---
at RedGate.SQLSourceControl.RepositoryBrowser.Tfs.TfsFolderTree.#xhob(IEnumerable`1 , VirtualTreeNode )
at RedGate.SQLSourceControl.RepositoryBrowser.VirtualTreeNodes.VirtualTreeNode.Refresh(NodeRefreshed onComplete)
at RedGate.SQLSourceControl.RepositoryBrowser.Tfs.TfsFolderTree.ConnectToServer(ISrcCLocation location)
at #gMc.#gU4b.#A2.#Tfc(ICancellableOperationStatus )
at RedGate.SQLSourceControl.Engine.Cancellables.MutexedCancellableOperation`1.#u3.#k5f()
at RedGate.SQLSourceControl.Engine.Cancellables.CancellableOperationBase.InvokeWithTracker(String featureUsageKey, Action action)
at RedGate.SQLSourceControl.Engine.Cancellables.MutexedCancellableOperation`1.Invoke()
at #JLc.#PLc.#Jfb.#EJf()
at RedGate.SQLSourceControl.Engine.SmartAssembly.ExceptionReporting.ErrorReporterBase.Do(Action , Predicate`1 , Boolean )
at RedGate.SQLSourceControl.Engine.SmartAssembly.ExceptionReporting.ErrorReporterBase.DoWithObviousExceptionsRethrowAll(Action action)
at RedGate.SQLSourceControl.CommonUI.Forms.ErrorDialog.DoWithObviousExceptionsRethrowAll(Action action)
at #JLc.#PLc.#CTc(ICancellableOperation`1 , Object )

Elliott Whitlow on


  • Are you trying to browse to set the folder after entering your credentials? It may be that you're not allowed to do that step.
    Instead, create the folder (if you haven't already done so) in your TFS structure outside of SQL Source Control, and then try linking with the paths fully entered in the link screen so you can just click "link" as opposed to needing to use the Browse button.

    Failing that; I'm not sure. We've had one or two people with similar problems accessing external TFS servers that we've never quite been able to work out and you may be running into something similar; but we can check logs etc. if needs be.
    Systems Software Engineer

    Redgate Software

  • No, I know the initial folder and I'm not even getting past credentials because it is telling me that I am entering invalid credentials. Although I know and have tried EXACTLY the same credentials both online and here.

    Elliott Whitlow on
  • OK, researching this a little more it seems that the authentication process can get a little more complex... can you check:

    - are you logged in to Windows on your computer as a domain or local user?
    - is the TFS server in the same domain or a different one? (or none)
    - is there a user on the TFS server the same as the one you're logged into Windows as?
    Systems Software Engineer

    Redgate Software

  • Hi, please try steps from this article
  • That link seems to contain the right information! Thank you very much!

    Elliott Whitlow on
Sign In or Register to comment.