What are the challenges you face when working across database platforms? Take the survey
Options

FILLFACTOR = 90 added to table scripts

jpeckhamjpeckham Posts: 4
edited November 20, 2012 12:53PM in SQL Compare Previous Versions
When I run SQL Compare from command line with /scriptfile option to DB it adds FILLFACTOR=90 to every table then I have to undo changes because those aren't in source control of the linked DB that I have.

This comes up often because I delete my db, restore a backup to do some troubleshooting, then use sqlcompare to reload it without unlinking or re-linking. It's a time saver for me because for some reason it takes 10minutes to link our database and it only takes me a few seconds to regenerate the DB from SQL Compare.

This is mostly just a nuisance that I have to go undo changes to get back to work.

Comments

  • Options
    Hi jpeckham,

    Thanks for your forum post. In regards to the fill factor setting, by default the command line doesnt set this option. You can try adding the following option to your command line to set the "Ignore Fill Factor setting":

    /options:IgnoreFillFactor

    Best Regards,
    Steve
    _________________
    Steve Tanori
    Product Support
    Red Gate Software Ltd.
    866-997-0378
Sign In or Register to comment.