What are the challenges you face when working across database platforms? Take the survey
Options

File Management / File Name Format

LehighDBALehighDBA Posts: 24
edited November 8, 2012 4:09PM in SQL Backup Previous Versions
Using 7.2.1.4. Trying to make the File Name Format as shown below.

<SERVER>_<INSTANCE>_<DATABASE>_<TYPE>_<DATETIME yyyymmdd_hhnnss>


No matter what I do (Click Apply, etc.) the information will not stay in the file name format box... it reverts back to the previous information.

What am I doing wrong?

Comments

  • Options
    It sounds like the user account which is assigned to the SQL Backup Agent service does not have Full Control permissions on the relevant location in the registry to make the change. Adding this should allow the new format to save.

    The REG_SZ key is:
    HKEY_LOCAL_MACHINE\SOFTWARE\Red Gate\SQL Backup\BackupSettingsGlobal\<Instance_Name>\BackupFileName
  • Options
    That was it. Thanks! :D

    Any way for the UI to detect this issue in the future? Not sure if there is an internal status that the UI is getting to indicate that the registry could not be written to.

    Also perhaps it could be included in the help file on the Security Model information, etc.
Sign In or Register to comment.