What are the challenges you face when working across database platforms? Take the survey
Options

Cannot load the Backup Reader dll (see inner exception)!

jskrilecjskrilec Posts: 4
Just installed the tool, 14-day trial.

Every time I try to connect to any of my SQL Server DBs I got the same error:

http://imageshack.us/a/img15/7000/75681287.png (cannot make this URL to work, you can copy/paste it)

My laptop runs Win7 64, I've also tried rebooting. Btw, the dll file is indeed within the application folder @ C:\Program Files (x86)\Red Gate\SQL Data Generator 2.

Any help will be much appreciated.

Thanks!

Comments

  • Options
    Thank you for your post.

    Are there any encrypted objects in the schema?
  • Options
    Not really, just an empty star-schema using IDs (int), text fields (varchar 50), and decimal fields for dollar figures.

    I've tried with two other DBs - on the same box - and got the same results. Haven't tried with a newly created DB.

    Thanks!
  • Options
    We have had a couple of other user reporting this problem. So far we are unsure why this is the case and the investigation continues. I have updated the bug report to include your details, which may help that investigation.

    Would it be possible for you to try this older version of the tool. Some users have found that it does not give the error for exactly the same databases.

    ftp://support.red-gate.com/patches/SQL_ ... .0.286.zip
  • Options
    Thanks for your help! I'm downloading the zip file now and I'll give it a try.
  • Options
    I'm having the same issue. Running Windows 8 x64 and MS SQL 2012 Developer Edition. Has there been a fix to this?
  • Options
    Unfortunately SQL Server 2012 is not yet supported by the tool. Are you able to connect to older versions of SQL Server? Assuming that you are, then it sounds like the development team need to take a look (and likely release a patch).
  • Options
    I am on windows 7 and running SQl server 2008 R2

    Initially I was getting the same error message.

    Looks like it worked after I created an empty database and script out all the tables that i need to mask to that new database. I then right click on the new database and open up the generator and it worked.

    this was on my test environment,.
Sign In or Register to comment.