Keeps showing uncommited changes even if there are none

needbrew99needbrew99 Posts: 8
Using TFS and the latest version, I keep getting the icon that there are changes to commit. When I open the tab to check, there are no changes to commit and the icon goes back to normal. A few seconds later it changes back and says there are changes to commit.

Comments

  • This sounds like a bug.

    Could you send me the DDL for the object that keeps popping up on the commit tab? It could be some syntax were not handling correctly.
    Chris
  • It keeps changing objects. If I open the SQL Source Control tab and it syncs up, there are no differences and the icons change to normal, almost immediately the icon changes to changed objects, and if I expand the tables folder or Stored procedures it will be a different one
  • Are you using the shared model? Could other users linked to the same database be committing the changes?
    Chris
  • Using the shared, but there are no other changes going on. When I Click on the Commit Changes Tab and it sync's up, the icons change in the Object Explorer to show nothing is different. Then when you click on something else, the change icon appears again.
  • ok, I think this needs investigating. Leave it with me.

    I take it you're on the latest version (3.1.0.4583)
    Chris
  • Was working fine before I upgraded to the new version.
  • Sorry for the delay.

    When using the shared model in the latest version (3.1) we now record the changes in a table called 'RG_AllObjects' in tempdb. If this table is removed or couldn't be created for whatever reason, then it might cause strange behaviour with the blue indicators.

    Could you check if you have this table and if it's populated with data?
    Chris
  • The table is there and is populated with 7183 rows of data
  • This is really getting to be a pain. Every DB shows as having changes to commit, even though nothing has changed.
  • This seems to be an issue with the query we use to check for changes. It seems to be picking up on all sorts of system objects that it should really filter out.

    We have had this and a few other problems with the 3.1 release, so we've actually now pulled it from the website until we fix these issues with the shared model.

    I would recommend downgrading to version 3.0 for the time being:
    http://downloads.red-gate.com/checkforu ... 3.4214.exe

    Sorry for the inconvenience.
    Chris
  • I am also getting random blue dots on databases where there are no changes to commit and where I know the database hasn't been changed behind the scenes.

    I am running version 3.1.0.4829 so do I still need to downgrade to version 3.0.13.4214.exe
  • I am also getting the same issue. I thought you had to be running at least v3.1 to use TFS service.

    By downgrading does that mean we cannot use Team Foundation Server Service?
  • PDinCAPDinCA Posts: 640 Silver 1
    Any update on this issue, please...?

    I'll live with the fake-blue-dots as I'm the only DB developer, but it is rather confusing to see.
    Jesus Christ: Lunatic, liar or Lord?
    Decide wisely...
  • Is there any update on this issue?

    It is becoming a big problem. Object explorer shows many items that it thinks need submitting, by highlighting with blue bubble, but SQL Source Control states no changes have been made. Getting to a stage where we might revert to another method of source control until a reliable version becomes is available.

    As stated in earlier post we cannot downgrade as we are using Team Foundation Service which is only supported in the latest release I was told.

    Any update would be most appreciated
  • PDinCAPDinCA Posts: 640 Silver 1
    This is NOT limited to TFS

    I have the persistently misleading blue dots with SVN.
    Jesus Christ: Lunatic, liar or Lord?
    Decide wisely...
  • Version 3.1.0.4829

    We work in a dedicated model and I am seeing this issue as well. Very big problem as we have 24 databases that we may have to work against on multiple instances and refreshing each one to see if there really are changes to commit is very very time consuming. Reminds me of the old MS DBproj process of building and deploying to your local.

    We have never worked in a shared model so I am not sure if the tempdb table is even relevant. I have checked and I do have that table and it has over 10622 rows in it.

    I am still not sure why these source control tools from RedGate don't use the physical files on the developers machines that are written out when they perform a get latest to their local workspace.

    Seems like the only source control aspect of SSC is the web service or command line operations for performing check-ins and associating the changes to work items for the relevant source control system.
  • An update on this - we've significantly improved the polling query in SQL Source Control, so this ought to be addressed in the next version. We're hoping to have that up on Check for Updates within the next few weeks.
    Andy Campbell Smith

    Red Gate Technical Support Engineer
  • Appreciate the update on this Andy and looking forward to the next release.
  • Thanks Andy. Looking forward to the updated release.
  • Andy.

    Do we have any further information on when the update will be available?

    Many Thanks
  • I have just downloaded and installed the latest update v3.1.0.5208. This seems to have resolved the issue.

    Many Thanks
  • So, I never had this issue until I upgraded to 3.1.0.5208. I'm using a dedicated model and all of the icons change if I work with different query tabs but when I go back to the SQL Source Control tab, it refreshes and the icons indicating changes are removed.
  • mmooremmoore Posts: 27 Bronze 3
    We are having this issue on a Dedicated Model w/ SSC 3.1.0.5208. This does not happen in 3.0.13.4213.

    I can get it to reproduce every time now.

    1. Close SSMS
    2. Open SSMS and connect to server
    3. Click on a database that is linked and that has no changes pending. Wait for it to finish comparing. (Click on "Get Latest" tab and wait for "no new changes in source control")
    4. Click on different database, can be linked or not, the database that was clicked in step 3 above, now shows that everything is out of data. (Blue circle on Green Server Icon and on every object in that database.)
    Mark Moore
    Software Engineer
    NTS Data Services, LLC
  • mmooremmoore Posts: 27 Bronze 3
    Any news on if and when this will be fixed. This did not happen for me, until the latest update of SSC 3.1.0.5208.

    Thank
    Mark Moore
    Software Engineer
    NTS Data Services, LLC
  • I am using version 3.1.2.33 and still experiencing the issue.
  • mmooremmoore Posts: 27 Bronze 3
    Just download and installed latest version 3.1.2.33, still same issue.

    1. Open SSMS
    2. Click on Linked Database
    3. Wait for it complete compairson
    4. Click on differetn Linked Database. Database in step 2 above now shows everything is out of data....
    Mark Moore
    Software Engineer
    NTS Data Services, LLC
  • This sounds like an issue with the new polling query - the polling query is a low-cost way for SQL Source Control to check which objects have been changed and need to be checked in, and it runs in the background. Since it doesn't do a full comparison, we've previously had trouble with the polling query reporting objects as changed that a full comparison doesn't.

    There's two ways you can work around this right now:

    1. Downgrade to a version of SQL Source Control that used the previous version of the polling query - the last version to use the old query was 3.0.13.4829, available here:
    ftp://support.red-gate.com/patches/SQLS ... 0.4829.exe

    You'll need to uninstall SQL Source Control and delete the following objects from tempdb before you run that installer:
    Table : RG_AllObjects
    Stored Procedures: RG_WhatsChanged
    Scalar functions : RG_PersistentTableVersion, RG_ProcVersion

    2. Disable polling in SQL Source Control. This means that you won't get blue blobs on objects without going to the Commit Changes tab yourself and performing the full comparison to source control.

    To do this, open %localappdata%\Red Gate\SQL Source Control 3\RedGate_SQLSourceControl_Engine_EngineOptions.xml and add the line
    <PollingEnabled>False</PollingEnabled>
    

    as a child of the main <EngineOptions> node.

    If there isn't a RedGate_SQLSourceControl_Engine_EngineOptions.xml file in that folder, you can create one yourself - the entire file contents should look like:
    &lt;?xml version="1.0" encoding="utf-8" standalone="yes"?&gt;
    &lt;!----&gt;
    &lt;EngineOptions version="3" type="EngineOptions"&gt;
      &lt;PollingEnabled&gt;False&lt;/PollingEnabled&gt;
    &lt;/EngineOptions&gt;
    
    Andy Campbell Smith

    Red Gate Technical Support Engineer
  • mmooremmoore Posts: 27 Bronze 3
    FYI: Still happening in lastest update
    Mark Moore
    Software Engineer
    NTS Data Services, LLC
  • Hi,

    The latest release (3.1.4.72) which was made available yesterday, has a fix that should stop blue blobs displayed following the first click on a database in a new Management Studio session.

    We are aware of some cases where blue blobs are erroneously shown later on in the workflow, but the initial startup one should be fixed.

    Could you try upgrading and see if that fixes the problem for you?

    Regards
    Chris
    Chris George
    SQL Source Control
    Red Gate Software
Sign In or Register to comment.