VDI 1010 Error when attempting to restore

lionheartlionheart Posts: 7
edited December 15, 2005 11:00AM in SQL Backup Previous Versions
I'm attempting to restore a full database back to a new database. I've tried this with the command line as well as the GUI (command line and error pasted below) from the database server (which also runs the backup). In the gui I've logged in as sa, my normal username and password, and tried using windows authentication and every time I get the same basic error when it's going to the screen to rename the files.

I'm trying to restore to a new database name (which doesn't exist now at all).

Here's the command line I've tried as well (which basically gives the same VDI error).

SQLBackupC -SQL "RESTORE DATABASE sfeed_restored FROM DISK = 'C:\data\sql\backups\FULL_(local)_sfeed_20051211 150001.sqb' WITH MOVE 'sfeed_data' TO 'c:\data\sql\databases\sfeed_restored.mdf', MOVE 'sfeed_log' TO 'c:\data\sql\databases\sfeed_restored.ldf' "

SQL Backup 3.2.0, (c) Red Gate Software Ltd 2004 - 2005

Restoring database sfeed_restored from "C:\data\sql\backups\FULL_(local)_sfeed_20051211 150001.sqb"

VDI error 1010: Failed to get configuration from server. Check that the SQL Server instance is running, and that you have the SQL Server Systems Administrator server role. Error code: -2139684861 (The api was waiting and the timeout interval had elapsed.)

Msg 3013, Level 16, State 1, Server DBSRVR, Line 1
RESTORE DATABASE is terminating abnormally.


Any assistance is greatly appreciated as I need to get this restored ASAP.

Thanks.

Don

Comments

  • peteypetey Posts: 2,358 New member
    Is that all the error? There should've been more. Could you pls check if the sfeed_restored database already exists (perhaps in a restoring or read-only state), and if files by the name of sfeed_restored.mdf and sfeed_restore.ldf file exists? Thanks.
    Peter Yeoh
    SQL Backup Consultant Developer
    Associate, Yohz Software
    Beyond compression - SQL Backup goodies under the hood, updated for version 8
  • That was the entire message. It didn't restore anything. I contacted support and got a minor upgrade but still no go. But we were able to restore using the extended stored procedure so at least the database is back.
  • Brian DonahueBrian Donahue Posts: 6,590 New member
    The restore was failing at RESTORE FILELISTONLY while trying to get the filenames from the full backup file. I suspect that the problem is down to Terminal Services (remote desktop) configuration on this server -- although it seems that SQL Backup could write the temp files just fine.
Sign In or Register to comment.