Comparing using command line show different but not in GUI

rrerre Posts: 42 Bronze 2
edited September 7, 2012 3:32PM in SQL Compare Previous Versions
When I comparing a snapshot folder with a database using the command line I getting differences, but there were identical and no differences were highlighted. For that I was using the following parameters in a special XML file:

After looking at the comparison report which is also generated by SQL Compare it shows me some objects with differences, but actually there looked identical.

Well, I try with the SQL Compare GUI and used the the same parameter I had used via the command line. The results was that it shows me no differences. Ok, this means is has something to do with the command line version of SQL Compare.

Well, after playing around with some parameters I tried to use the same constraint names in my snapshot folder and my target database to avoid this differences in general although I used the particular option to ignore it. After renaming the constraints on both targets my problem was solved.

I like to share my experience with this strange behavior of the command line from SQL Compare. May be you can reproduce it your environment.
If you need any further information, please let me know.

I used SQL Compare Version


  • Hi rre,

    Thanks for your post. We have opened a support ticket for you in regards to this issue. I will be in contact with you shortly.

    Steve Tanori
    Product Support
    Red Gate Software Ltd.
Sign In or Register to comment.