Error parsing file when attempting to commit changes

tlentinetlentine Posts: 6 Bronze 1
edited September 16, 2012 6:50PM in SQL Source Control Previous Versions
I am using SQL Server Management Studio 2012 with SQL Source Control Version

When attempting to either Commit Changes or Get Latest I repeatedly receive an error similar to the following:

There was an error parsing the file "%appdata%\local\Red Gate\SQL Source Control 3\Transients-Vault\some gibberish\Tables\TableName.sql

The odd thing is that if I refresh the page the same error will appear with a different table or sproc name.

I am unable to move past these sets of errors to check code in or pull code from source control.

Any idea what might be causing this issue and how to correct it?

Thanks in advance.


  • I am evaluating both SQL Connect and SQL Source Control to improve our SQL developer experience as the Visual Studio tools have a long way to go yet. But at initial set up with either tool, I have run across the "error parsing" message on a number of our stored procedures. I've tried cleaning up the queries but some of them are quite simple (i.e. Update table set column = value where id = @id). There's not much to fix with that query but somehow I cannot get past this error. Is there a way around this issue?

    I am using SSMS 10.50.2500.0 with TFS 2012. I also tried against TFS 2010 but got the same error.
  • In my case, every single file has a GO statement without a newline character in front of it (e.g.:


    It should look like this:

    ) ON [PRIMARY]

    Maybe the linefeed/carraige return is incorrect in the file generated by Redgate Source Control.
  • Hi,

    Thanks for your post. If you are using any new SQL Server objects that were introduced with SQL Server 2012, they are not yet compatible with SQL Source Control and will throw errors.

    We have opened a support case and will be following up with you shortly.

    Best Regards,
    Steve Tanori
    Steve Tanori
    Product Support
    Red Gate Software Ltd.
  • That makes sense. I scripted a database from Azure to a local server. I probably forgot to change the destination server type to Local SQL Server with the tool I use for database migration.

    The wierd part is Source Control has no problem with the Azure server. Only the local server.

Sign In or Register to comment.