Workaround for performance issues on large database schemas

David AtkinsonDavid Atkinson Posts: 1,376 Rose Gold 2
edited July 10, 2012 8:11AM in SQL Prompt Previous Versions
If you are having issues with SQL Prompt as it tries to cache databases with a very large number of schema objects, the following option is available to you.

As of SQL Prompt 5.3 you can edit %LOCALAPPDATA%\Red Gate\SQL Prompt 5\RedGate_SqlPrompt_Engine_EngineOptions.xml and change <MaxSupportedColumns> to a value like 2000000.

Any database with more than the configured total number of columns across all tables will just not be cached by SQL Prompt.
David Atkinson
Product Manager
Redgate Software
Sign In or Register to comment.