What are the challenges you face when working across database platforms? Take the survey
Options

Server Problem where there was none before: Cannot connect

SQL_ME_RICHSQL_ME_RICH Posts: 112
edited June 14, 2012 8:57PM in SQL Backup Previous Versions
Hello -

My trial license expired on my workstation copy of SQL Backup 7, and ever since then - one of my PROD servers is Red X'd out of my list, and give the following error in a dialog box:

A problem was encountered whilst communicating with the server.

A network-related or instance-specific error occurred while establishing a connection to SQL Server. The server was not found or was not accessible. Verify that the instance name is correct and that SQL Server is configured to allow remote connections. (provider: Named Pipes PRovider, error: 40 - Count not open a connection to SQL Server)

Now - I have done the following:

- Verified through Surface Area Configuration that both local and remote connections are being allowed via TCP/IP and named pipes.

- Checked to make sure the service was running (the server shows up find in it's licensed copy on the server itself, just not from my workstation console).

- Made sure the credentials being used to access said server had not changed and were still being used.

Any and all ideas to get this working again would be appreciated.

SQL_ME_RICH

Comments

  • Options
    chriskellychriskelly Posts: 378
    edited June 14, 2012 7:37PM
    On your desktop machine, where the SQL Backup UI is located, are you able to connect from here to the Prod machine using SSMS?
  • Options
    Nothing is on my desktop, but if what you are asking me is if I go into SSMS and connect to that database instance via my local copy of SSMS, does it connect? The answer is yes it does (and I am using SQL Auth both for Red Gate and the SSMS connection to it).
  • Options
    How are you specifying the machine and sql server name you are wanting to connect to? have you tried specifying the relevant port? e.g. chrisk5\sql2008r2:1433
  • Options
    Nothing about the connection string has changed since it first worked. No port is being specified when I specify the server name (and I have done it both by IP Address and Machine Name in the past with success in either case), but right now it is using the machine name, and is not working. I tried switching it over to just the IP address, but have the same results.



    EDIT: I now have it working via IP address with SQL Authentication. This did not happen before. Let me try this for a bit, and see if I can determine why it is having trouble with the machine name. If I wind up having troiuble still - I will post back.
  • Options
    I have to tell you though - this kind of bothers me. I have 2 other instances that I have in my copy here locally, along with this one (that I now have to access via IP address). The 2 others are access the instances with no problem, using the Server names. If it were a DNS problem - I would think that the effects from such an issue would be seen elsewhere with other things, but nothing else is amiss here.

    Any ideas on why this one server would not resolve my server name, but has no issues with the other 2? Have you had an issue like this in the past?
  • Options
    OK - it definitely is a configuration issue on our end. 1 of the 3 servers is in our corporate domain while the other 2 are not. This has actually opened up a whole other can of worms, so just know that I am working fine again.
Sign In or Register to comment.