What are the challenges you face when working across database platforms? Take the survey
Options

10.2.0.696 compression always ignored

ahribernikahribernik Posts: 12
edited May 24, 2012 9:34PM in SQL Compare Previous Versions
Upgraded to 10.2.0.696 and now compression seems to always be ignored regardless of the configuration setting.

source database has a table with PAGE compression on table and indexes target does not have compression.

source and target are SQL 2008 R2
red gate compare v10.2.0.696
ignore data compression is OFF

Comments

  • Options
    Hi ahribernik,

    Sorry you are having a problem with Compare. I've been trying to recreate the issue you are reporting but to no avail.

    I've tried with the following objects:

    source

    CREATE TABLE T1
    (c1 int, c2 nvarchar(50) )
    GO

    CREATE NONCLUSTERED INDEX IX_INDEX_1
    ON T1 (C2)
    GO

    and target


    CREATE TABLE T1
    (c1 int, c2 nvarchar(50) )
    WITH (DATA_COMPRESSION = PAGE);
    GO

    CREATE NONCLUSTERED INDEX IX_INDEX_1
    ON T1 (C2)
    WITH ( DATA_COMPRESSION = PAGE ) ;
    GO


    and the ignore data compression option seems to work. Can you give me a specific example?

    Thanks,
    Neil
  • Options
    Hi Niel, please try the reverse scenario with the source having compressed objects.
  • Options
    Hi ahribernik,

    Thanks for your response. I'm still failing to reproduce the problem.

    In your scenario are you using a saved project file from the previously released version of Compare? Does the problem persist if you create a new project or do a comparison without saving it as a project?

    Thanks,
    Neil
  • Options
    Hi Niel,

    I can repeat the behavior even with a new project

    In an effort to provide you with a script I found out that this did not occur if i created 2 new databases and tables to compare.

    I still however experience the problem with my existing database to a new target database.

    Could this be a cache issue? Is it shared with SQL Source Control (I am experiencing a similar problem with that also)?
Sign In or Register to comment.