What are the challenges you face when working across database platforms? Take the survey
Options

Error 880

kthiongokthiongo Posts: 3
edited May 11, 2012 9:55AM in SQL Backup Previous Versions
Backup Jobs keep failing with the error message

5/9/2012 4:21:34 PM: Error 880: BACKUP DATABASE permission denied in database: (db_name)
5/9/2012 4:21:34 PM: SQL error 15157: Setuser failed because of one of the following reasons: the database principal 'DOMAIN\USER' does not exist, its corresponding server principal does not have server access, this type of database principal cannot be impersonated, or you do not have permission.

The registry fix listed on the site doesn't work. :(

Comments

  • Options
    When you say that the registry fix doesn't work, could you give some clarification? Were you unable to locate the registry key, or create it, or something else?
  • Options
    We have a 64bit system so i added the SkipChecks registry key to
    HKEY_LOCAL MACHINE\Software\Wow6432\Red Gate\SQL Backup\BackupSettingsGlobal\(LOCAL)

    that didn't fix it

    i tried the fix on the
    HKEY_LOCAL MACHINE\Software\Red Gate\SQL Backup\BackupSettingsGlobal\(LOCAL) folder and it worked
Sign In or Register to comment.