SSC not picking up static data update

jhildenjhilden Posts: 12
I'm using SSC on SSMS 2012 and I found the following:

I am tracking static data on a table with 3 columns, 6 rows. I updated the last column in each row and found that SSC did not pick up that change.

I then added a new row to that table, after that SSC noticed the change to all the rows.

I then removed the new row that I added and SSC finally noticed that the data had changed with my original 6 rows.

After committing the change I tried to generate a migration script only to find it bombed saying that it couldn't create a script because there were no structure changes. My team was hoping to use this tool to manage migration of DB changes between different environments, not just different developers. Is this not going to work for us?

Thanks in advance!

P.S.: Astroids rocks!


  • Hi jhilden,

    I tried out the scenario you mentioned in your post, and it seems to be working on my test machine. Please make sure you are hitting the "Refresh List" icon next to the commit button on the Commit Changes tab. If you are pressing the refresh, please provide a sample schema for your table (create table script) that you are experiencing this issue with and Ill give it a try in my environment.

    Steve Tanori
    Product Support
    Red Gate Software Ltd.
  • Regarding the point about add a migration over a data-only change, this is a known issue. Could you please vote for it here? ... to-any-dat

    The workaround is to put your data migration SQL at the start or end of a schema change.

    David Atkinson
    Product Manager
    Red Gate
    David Atkinson
    Product Manager
    Redgate Software
  • David, thank you for your reply. Please advise me on the following scenario:

    I have just committed a change that has static data only. How can I create a custom migration script for that change? When I try I get the error:
    SQL Source control cannot create a migration script because the revisions you selected contain no schema changes, only data or metadata changes.

    What is my work around now for generating a change script? I'd be happy to create the .sql file myself but when I look in SVN there is an associated .migrationScript file that I wouldn't also need to mimic. That would be quite error prone.

    Any advice you have would be appreciated.
  • David, I just saw your reply on the voting page:
    The workaround for this is to prefix or suffix the code to a schema change. It's not ideal, but should work. Please vote for this issue if it affects you and hopefully we'll be able to implement a better fix.

    I can accept that for now but putting in data changes into this product would make it much, much easier to use!

Sign In or Register to comment.