Competition: What’s your favorite Redgate tool? Enter now.

Cannot copy/paste from Search text

andomarandomar Posts: 17
edited April 3, 2014 5:50AM in SQL Search Previous Versions
Hi,

I recently upgraded to SSMS 2012.

When I try to copy/paste from SQL Search, this error appears:

2hp7rwn.png

This is fairly inconvenient, is this a known issue?

Thanks for your reply,
Wessel Troost

Comments

  • PDinCAPDinCA Posts: 642 Silver 1
    It gets worse. If you take note of the 2nd sentence in the dialog, it talks about not having a saved document... So, I clicked the SAVE button!

    It brings up the save dialog per usual - looking good... BUT, once the file name has been assigned and the document saved, notice that the tab titile doesn't change. If you happened to have ANOTHER SQL Script open (I had just opened a Modify of an SP), THAT now bears the name you just assigned.

    On the plus side, you can now highlight and Ctrl+C.

    So, my advice is to open an empty query then open SQL Search, save, ostensibly, the SQL Search document, and leave the empty script open. Fudge - yes, but it works...

    Now if only Red Gate had added an auto-response to this original ticket 10 months ago...

    Care to fix this simple thing, please, Red Gate - SSMS2012 is now mainstream......
    Jesus Christ: Lunatic, liar or Lord?
    Decide wisely...
  • I keep 2 instances of SSMS 2012 running - one with SQL Search another without. The one with SQL Search does not have any tabs open, so you can copy in one instance of SSMS and paste to another.
  • We are looking into resolving this issue, however it seems likely that this is out of our control as SSMS could be intercepting the Ctrl + C before it ever reaches SQL Search.

    The current work-around for this is to either close or save any unsaved query windows. The forthcoming release will also have 'copy' added to the right-click context menu.

    If the symptom described above is not what you are experiencing, or you have anything further to add to this issue, we'd be grateful for more information.

    Thanks,
    Adam
    SQL Search Development Team
  • We’ve continued to research into this bug and have found a fix.

    Steps:

    - Restart SSMS
    - Go to Tools -> Options
    - Expand “Environmentâ€
Sign In or Register to comment.