Competition: What’s your favorite Redgate tool? Enter now.

Search now needs .NET 3.5 (Addin fails to load without it)

james.allisonjames.allison Posts: 8
edited January 18, 2012 9:56AM in SQL Search Previous Versions
SQL Search version 1.1 has a requirement for .NET Framework 3.5.

The initial release did not check for this prerequisite during installation, or on auto-updating of an existing installation. This has resulted in SQL Search crashing on machines without .NET Framework 3.5 each time SSMS is started, typically with the error details:

‘Could not load file or assembly 'System.Core, Version=3.5.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089' or one of its dependencies. The system cannot find the file specified.’

To correct this issue, please install .NET Framework 3.5, available from Microsoft’s website at http://www.microsoft.com/download/en/details.aspx?id=22
(Please note that the .NET Framework 4 does not include 3.5 - 3.5 must be installed separately even if 4 is present)

Many apologies for any inconvenience this may have caused.
James Allison

Software Engineer - SQL Prompt
Red Gate Software Ltd.
Sign In or Register to comment.