SyncScriptEncoding UTF8 includes a preamble

ladenedgeladenedge Posts: 4
It says in Switches used in the command line that the default should result in a UTF-8 encoding without a BOM. However, when I omit this switch in Data Compare 9, I do indeed get a BOM. In addition, I tried explicitly setting the option in all of the following ways:
  • /SyncScriptEncoding:UTF8
  • /SyncScriptEncoding:UTF8WithPreamble
  • /SyncScriptEncoding:UTF8WithoutPreamble
All of them seem to result in a UTF-8 file that includes a BOM. The ASCII argument worked as advertised.

I feel pretty certain this option is broken, but perhaps I was missing something on my end?

Comments

  • Brian DonahueBrian Donahue Posts: 6,590 New member
    Thanks for letting us know about this. I have logged a bug with reference number SDC-1301 so this will get fixed.

    Regardless of whether you use UTF8 or UTF8WithPreamble, the preamble gets written to the file, contrary to the documentation. I had a look at the bytes of the sync script file, and with either option the file starts with xEFBBBF.
Sign In or Register to comment.