version 10 - tries to create db for remote dbs

integragroupintegragroup Posts: 6 Bronze 2
edited January 11, 2012 9:32AM in SQL Compare Previous Versions
Just updated to v 10. Tried to compare two remote databases that I had compared multiple times with v 9.x and now v10 is saying "New Database", the target database you specified does not exist.

I selected database to database
remote server is the same in both cases
and I selected the two databases from the drop down

Local to local of a backup/restore of these two databases do not present this issue.

Did SQL Compare become only usable on the box on which it is installed or am I missing something


  • Options
    Hi integragroup,

    v10 of SQL Compare allows you to create a new database straight from the edit project dialog. Compare checks if the database specified in the database name field exists and if not it presents you with the option to create one.

    It seems in your case Compare is acting strangely. If you picked the db names from the dropdown then they exist, so you shouldn't get the "Create Database" screen when you hit compare now.

    Can you give me some more detail about the error? What version of SQL Server are your remote dbs on? What are the database names? Is there anything special/different about them? Does this happen all the time for you?

  • Options
    It appears this could be related to SQL Server 2000.
    We are in the process of migrating over to 2008 so I tested it between 2 dbs on the 2008 server and it behaved as desired.

    I don't get an error, I get the "New Database" prompt indicating "The target database you specified does not exist".

    The interesting thing here is the Database Name is the name of the Source database for the comparison.
  • Options
    lnuzumlnuzum Posts: 3 Bronze 1
    I just installed the new 10 version and I'm having the same issue comparing a SQL2008 to SQL2000 database. It's forcing me to try to create a new one and no option to get past this. Does the new version no longer support SQL2000? That would be bad.
  • Options
    Hi guys,

    Thanks for pointing out this issue. I've made a fix and uploaded it here:

    http://downloads.red-gate.com/checkforu ... .0.160.exe

    Please give that a go and let me know if it fixes the SQL 2000 problem.

    Happy New Year!

  • Options
    Did a quick test and it looked like it was going to work. Will perform additional tests today and will report back if anything new develops.
  • Options

    I was getting this as well after upgrading, so I installed the new build..
    Now my SQL Compare is crashing upon startup, like I was experiencing at one time, using version 9.

    Looking at the email from that time, then it was a AV/Firewall issue, but I cannot see anything in the log this time around.

    Debugging the application, I get this exception:

    An attempt was made to access a socket in a way forbidden by its access permissions
    at System.Net.Sockets.Socket.DoBind(EndPoint endPointSnapshot, SocketAddress socketAddress)
    at System.Net.Sockets.Socket.Bind(EndPoint localEP)
    at #Ahw.#Fhw.#PdC(Int32 nMilliSecondsToWait)
    at #Ahw.#Fhw.#PdC()
    at System.Threading.ThreadHelper.ThreadStart_Context(Object state)
    at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state)
    at System.Threading.ThreadHelper.ThreadStart()

    My previous problem was logged with the number F0050810.

    -- Regards, Morten
  • Options
    Okay, it was the same error again, but somehow it didn't affect SQL Compare 10 before I installed the .160 version, how peculiar..

    -- Cheers, Morten
  • Options
    I can confirm as working properly for me.

    -- Regards, Morten
  • Options
    jmeyerjmeyer Posts: 70 Bronze 2
    I can also confirm that .160 solved this issue for us under SQL Server 2000.

  • Options
    The .160 fix worked for me as well; we were experiencing the same problems.
  • Options
    Ditto for us. We were deploying from SQL Server 2008 R2 to SQL Server 2000. The .160 release fixed the issue.
  • Options
    I was having the same issue after upgrading, trying to compare two SQL 2000 DBs.

    The fix resolved the issue. Cheers.
  • Options
    DennisRehmDennisRehm Posts: 13 Bronze 2
    The fix solved the problem for me, too.
Sign In or Register to comment.