What are the challenges you face when working across database platforms? Take the survey


rcd.guerrarcd.guerra Posts: 15

my SQL Server db has correct collation "Latin1_General_CI_AS".

If i update some varchar column with the value "Comité" for instance it is commited correctly.

When i'm generating data from the tool, it is complying with the db collation.

For instance, the value "Comité" is inserted as "Comit�".

Does anyone have a clue why this is happening ?

Thanks in advance!

Best regards,


  • Options
    Eddie DEddie D Posts: 1,789 Rose Gold 5
    Thank you for your post into the forum and sorry that you have encountered a problem.

    What collation is the database configured to use?

    If different, what is the collation of this particular varchar column?

    What Windows language setting and keyboard layout are you using?

    Many Thanks
    Eddie Davis
    Senior Product Support Engineer
    Redgate Software Ltd
    Email: support@red-gate.com
  • Options
    Hi Eddie,

    thanks for your post.

    The db and particular column use the same collation, Latin1_General_CI_AS.

    Windows Language is en-US.

    Default input language is pt-PT (Portuguese).

    Keyboard layout is en-US

    Thanks for your time.
  • Options
    Thanks for coming back to us.

    I've just set up a DB using that collation and used Data Generator to insert "Comité" into a varchar(50) column. It seemed to work correctly (querying the table in SSMS shows the value correctly).

    Could you tell us a little more about what generator you are using for that column, how you're specifying the values and so on?
    Systems Software Engineer

    Redgate Software

  • Options
    Hi, thanks for your post.

    We are using a FileList generator having a file containing a set of values with accents.

    I've tried changing that file encoding but no success either.
  • Options
    We've also tried running Data Generator against another db server and database but with the same result.

    Can you explain how does the generator fills the values in the preview so we can also debug what might be wrong here ?

    Thanks a lot!

  • Options
    Is it possible for you to mail the file you're using to support@red-gate.com with F0053639 as a subject line? I'd like to try it myself. I've seen something similar before and I'm fairly sure it was the file encoding, but if I can test it out myself I can be sure.
    Systems Software Engineer

    Redgate Software

  • Options
    James, just sent the email.

    Thanks a lot!
  • Options
    In case anyone else runs into this, the solution was to open the file containing the text list to be used with SQL Data Generator in Notepad, and then go to File > Save As.

    Ensure "UTF-8" is selected as the file type, then save it.
    Systems Software Engineer

    Redgate Software

Sign In or Register to comment.