Error when linking a database to Subversion

mvargasmvargas Posts: 3
I get the error: An item with the same key has already been added. I was linking my database using a Shared database Development Model as usual.

I removed the SVN folder and created a new one for this database. After linking to the new folder, tried commiting changes but error comes up.

Now I'm not able to link this database to my Source Control.

My installed version is

Any ideas on how to solve this issue?


  • I was able to fix my issue! By using SQL Compare I found a suspicious "duplicate" object, a table with a name starting with blank space like this [ table_name] and my regular table [table_name].
    As soon as I removed the one starting with blank space I tried linking the database to Source Control and then committed my changes successfully. Again I'm using Subversion and probably the file name for my table object was really duplicated at the folder level.
  • Thanks for posting back here with your findings - a couple of other customers have reported similar errors directly to us recently, so it gives us another thing to check over with them!
    Systems Software Engineer

    Redgate Software

Sign In or Register to comment.