Error code: -2139684860

warren2600warren2600 Posts: 10
edited December 4, 2005 2:49PM in SQL Backup Previous Versions
I've been fairly happy with red gate, until about 12:15am this morning.
Today i've suddenly received the following error:
Error code: -2139684860

My automated backups are run using a stored proc and have worked flawlessly for over a month.
The same procedure is working smoothly on 3 identical clusters.
The strangest thing is that my full backups were failing, but my transaction log backups are still working.
** a 1K file is written to local disk, but nothing else.
** tried this with and without the -E flag...both do not work.

here is an example of one of the database backups which is not happening:
master..sqlbackup'-SQL "BACKUP DATABASE [server22] TO DISK = ''D:\server22\server22_db_FULLBACKUP_200511171508.sqb'' WITH NAME = ''Database (server22) Full'',  COPYTO =''\\sql4kbackup\D$\server22\'',
ERASEFILES = 7, COMPRESSION = 1"'


SQLBACKUP ERROR:
SQL Backup 3.2.0.5, (c) Red Gate Software Ltd 2004 - 2005
Serial number: 010-005-025534-D183
Backing up server12 (full database) to D:\server12\server12_db_FULLBACKUP_200511171424.sqb ...
Thread 0 error:
Process terminated unexpectedly. Error code: -2139684860
Msg 3013, Level 16, State 1, Server SQLCLUSTER, Line 1
BACKUP DATABASE is terminating abnormally.



last few lines in SQLBACKUPERRORLOG:


2005/11/17 14:24:23 pid(3012) tid(3928)
Error on Global\SQLBACKUP_{C97583B4-DAF5-4FB8-AB86-87F2377D5981}
Error at ServerBufferAreaManager::Allocate: Map buffers Status Code: 8, x8
Explanation: Not enough storage is available to process this command.



2005/11/17 14:24:23 pid(3012) tid(3928)
Error on Global\SQLBACKUP_{C97583B4-DAF5-4FB8-AB86-87F2377D5981}
Error at TriggerAbort: invoked

2005/11/17 14:24:23 pid(4068) tid(3920)
Error on Global\SQLBACKUP_{C97583B4-DAF5-4FB8-AB86-87F2377D5981}
Error at CVD::GetCommand: AbortDetected




last few lines in SQLERRORLOG:
2005-11-17 14:46:26.51 spid158 BackupVirtualDeviceFile::RequestDurableMedia: Flush failure on backup device 'SQLBACKUP_{ABF9C4C4-A2E2-4F3B-8B25-63E9287970E5}'. Operating system error 995(The I/O operation has been aborted because of either a thread exit or an application request.).
2005-11-17 14:46:28.05 spid59 BackupVirtualDeviceSet::SetBufferParms: Request large buffers failure on backup device 'SQLBACKUP_{99412029-F1D5-49E3-9EA3-7F3E4DAA506D}'. Operating system error 0x80070008(Not enough storage is available to process this command.).
2005-11-17 14:46:28.05 backup BACKUP failed to complete the command BACKUP DATABASE [server2] TO VIRTUAL_DEVICE = 'SQLBACKUP_{99412029-F1D5-49E3-9EA3-7F3E4DAA506D}' WITH BLOCKSIZE = 65536, MAXTRANSFERSIZE = 1048576, NAME = 'Database (server2) Full', DESCRIPTION = '', FORMAT


I've read that this is a memory issue?
what will make this not happen again? simply restarting the services or machine is unnaceptable.
i've since taken red-gate off of backup duties, and native sql works with no errors.

Please help.

Thanks,
Warren

Comments

  • Since posting, i've opened up the GUI and successfully backed up a database, which would not backup using the extended sp.
    After this, i tried re-running my sp and it is now working!??????
    Although this is good news, my desire to retain my job will not let me reinstate sqlbackup until this problem is addressed.

    Thanks,
    Warren
  • Brian DonahueBrian Donahue Posts: 6,590 New member
    Please keep in mind that if you are backing up over a network share, your account needs to have rights to that share.

    This would explain why the backups work interactivaly through the GUI, but not using the XP with Query Analyzer or SQL Agent. You'll need to make sure that the logon accounts that SQL Server and the Agent run under also have rights to the share.

    This can be particularly tricky if your SQL Server is running as LocalSystem. Typically, a computer's account doesn't have any access to anything outside of that computer.
  • I am aware of the permission concern.
    However, i'm using an account which is an administrator on the the sql cluster and on the standby server.
    My transaction log backups were not inturrupted, only the full backups.
    Again, this was something the just suddenly stopped working.
    I have not changed anything on the network/permission side.
  • Brian DonahueBrian Donahue Posts: 6,590 New member
    Hi Warren,

    I'm used to 'not enough storage...' errors being caused by NetBios connections but that's not to say there couldn't be other reasons.

    Is this server particularly overworked? Could it simply be running out of resources such as memory?
  • just a quick update:

    3.2.0.10 patch seemed to fix the issue
  • Brian DonahueBrian Donahue Posts: 6,590 New member
    Hello Warren,

    That is good news! Thanks a lot for your reply to this topic.
Sign In or Register to comment.